Skip to main content

Battery "Not charging"; Replaced PRAM Battery, no luck

PowerBook G4 15" 1.67GHZ

Had an older battery (replaced as part of recall) that was not charging. I replaced the battery and AC adapter, which was also flakey. Still not charging. After resetting PRAM and NVRAM, decided to replace the PRAM battery. Still no joy. Is my next step to replace the DC IN?

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요

아이폰 배터리 수리 키트

Only $29.99

Buy Now

아이폰 배터리 수리 키트

Only $29.99

Buy Now

2개의 답변

선택된 해법

What color lights are you getting on you AC charger jack? Please download and run Coconut Battery so we can get a better idea of what's going on. There's a new version but I don't know if it runs on the older machines: http://www.coconut-flavour.com/coconutba...

We are probably looking at either the DC-IN board or the battery connector. Visually examine them for corrosion. Please let us know your results. Thanks

해당 답변은 도움이 되었습니까?

점수 4

댓글:

current battery charge 4320 mAh

max batt charge 65308

current batt capacity 65308

original batt cap 4607

battery-loadcycles 0

charger connected yes

batt is charging no

The original AC charger is flakey and I replaced it with a 3rd party 65w one with no lights. When I use the original, it's yellow for a few min and then turns green. Similarly, if I start coconut when the machine is first powered on, it does say "charging yes", but that eventually flips to no (same with the battery icon, which shows 10 hours to charge initially, before changing to not charging).

The connector looks very clean, even under a bright LED light.

의 답변

Since you new battery has never been recharged I would first check the logicboard connection to the battery connector, that failing replace it: PowerBook G4 Aluminum 15" 1.5-1.67 GHz Battery Connector Replacement

Here's the part: G4 Aluminum 15" 1.5/1.67 GHz Battery Connector

의 답변

Installed the new battery connector and still no luck. I also found the original battery and it also shows no cycles in coconut, and it's a battery I used for years. Further, the machine would not power up with the AC adapter plugged in and either no battery or the totally dead old battery. Does that tell you anything?

Thanks. Mike

의 답변

I think I'm giving up.

의 답변

의견 추가하세요

This is a year old question. So, I may be too late to answer it, but I had the same problem. Coconut showed battery life good, charger connected, charging no. I removed the battery with the laptop bottom facing down and a little screw fell out. I reinstalled that battery screw and tightened up the other screw too. In my case, that did it. Now, the battery is charging again. Good luck.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

msilver336 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 1

지난 30일: 17

전체 시간: 3,199