주요 콘텐츠로 건너뛰기

2011년 하반기 모델, A1278 / 2.4 GHz i5 또는 2.8GHz i7 프로세서.

593 질문 전체 보기

Possible faulty cpu temperature sensor spikes but no errors from ASD

Hi all,

So I've been having a recurring problem on my late 2011 MBP, which from googling seems somewhat common - but I can't seem to resolve my specific problem. I am currently on High Sierra (10.13.5).

Basically kernal_task spikes to 200-5000% -> fans spin up full -> my macbook obviously then acts sluggish for 5-10 seconds but sometimes longer.

This coincides with what I think are incorrect temperature sensor readings, running TG Pro, (jumping from 50C to 100+ and then dropping back down). Now I understand that kernal_task is there for a whole load of reasons - and it is not the problem but a symptom, its purpose I believe in this case is that it thinks the laptop is overheating, so it blocks of cpu cycles to help stop the machine overheating.

Things I have tried to remedy this situation (from suggestions on other topics):

Reset PRAM and SMC

Replace non-oem battery with original

Clean fan and dust from machine

Clean heatsink, cpu and reapply Thermal paste

Clean Reinstall of OS 10.13.5

Running Diagnostics - all clear (except for battery warning, which has since been replaced)

Running Apple Service Diagnostics software (both kinds) - All clear

Run Etre check - Nothing that stands out as an issue

Run TG Pro - Here I have seen temperatures with strange values and large spikes (despite TG Pro saying "temperature sensors appear to be normal"

Additional Notes:

I have an SSD in the old HDD slot.

Running in safe mode I haven't run into the problem or at least it didn't occur in the couple of hours or so I tested it for.

It still occurs on a cloned version of my OS running via usb

My conclusion is probably that the sensor is bad and I likely need to replace the motherboard - but I'm hoping that there might still be a solution out there.


답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 1개

Can you post a snapshot of TG Pro that shows all of the sensors and shows this condition (post a few snaps in quick order or a vid) so we can see the odd sensor values. 기존 질문에 이미지 추가하기

댓글 달기

답변 3개

선택된 해법

As for the kernal_task process. Thats the root process everything hangs off of. And you are correct its not the root issue, I'm suspecting you have a very basic issue.

Bear with me as I explain…

Since you upgraded your system to High Sierra you're now using a new file system on your SSD drive! GUID/APFS whereas when you were running Sierra or older you were running GUID/Journaled (HFS+). APFS has issues running on SATA based drives! So I try not to run it on older Mac systems.

But lets put that aside right now as you still have a hardware level issue that many Unibody MacBook Pro's have and thats the HD SATA cable. Here we have seen in both the 13 & 15" models the rough surface of the aluminum uppercase wears the cable over time as well as the flexing of the corner folds breakdown the foil wires inside of the ribbon cable. In the 15" the plastic mid plane frame clips break and a good hit on the bottom cover can damage the cable as well.

As a point of process I always replace the cable when I switch out a HD for a SSHD or SSD as these drives can encounter issues with a weaken cable as the data flows are higher through the cable. So here is the cable I would use: MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable and yes this is a 2012 cable! And here is the guide to follow: MacBook Pro 13" Unibody Late 2011 Hard Drive Cable Replacement In addition I would place some electricians tape across the upper case where the cable rests and not over crease the folds.

The next thing here is the drive maybe slightly corrupted so I would make a fresh backup (TimeMachine) after installing the cable then reformatting the drive and restoring from the backup so no residual issues would pop up. Even still I would roll back to Sierra and hopefully by this falls release of Mojave this will be fixed.

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable 이미지


MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable


해당 답변은 도움이 되었습니까?

점수 3

댓글 12개:

Thanks for the reply.

So, yes from other posts on here I've heard that the sata cables can indeed get damaged. But I felt that running a clone from USB kind of ruled this possibility out?

Additionally, I think when I originally upgraded to HS I wasn't on the new file system, but I have recently formatted the SSD to APFS and then installed a fresh copy of HS (then used migration assistant to move the files from a cloned version)

Are you sure it did boot up from the USB drive? I've chased my tail a few times thinking it had only to find it hadn't ;-}

Apple's OS installer automagically updates the SSD to APFS! It knows! There is a way to tell the installer script to not upgrade the OS Is It Possible Not to Convert to APFS When Upgrading to High Sierra?. I rolled back as it was just too buggy on a SATA drive.

I will double check now, but I'm pretty sure it was from the HDD over usb just because of how slow it was. Out of interest is that sata cable just for the original HDD location, as I also have a drive in an optical bay caddy

The SATA optical drive bay uses a different cable (Optical Drive, Flex Cable - Apple P/N 922-9770). But be careful here! Some models of MacBook Pro's don't play nice with SATA III drives. Review your system against this: OWC Data Doubler compatibility listing. The issue is within the system not the drive carrier. If you have a Red noted system you'll need to make sure you've put in a fixed speed SATA II (3.0 Gb/s) drive and make sure the HD bay drive is your boot drive.

Ok, so I was definitely booting into the usb OS. However in the mindset of it being a hdd cable problem I unmounted the SSD once it booted. And this seemed to stop this issue - at least for the two or so hours I tested it. I think possibly when I've attempted before spotlight would have indexed the ssd and maybe had some issues there.

I did have one moment when I tried to ramp up the cpu and it stuttered for a bit and there was no temp reading - but no sign of kernal_task, so perhaps the monitoring app was stuttering too, resulting in those readings.

Best bet will be to get the cable and see if that helps.

Out of interest why use the 2012 cable on the late 2011 model?

댓글 7개 더보기

댓글 달기

Take a close look at the logic board where them crimped ends of the heat sink are and see if you can discern an oily type of stain on the board.

해당 답변은 도움이 되었습니까?

점수 1

댓글 3개:

@mayer - Have you been encountering a lot of heatsink failures? I had a run last year (6 or 7 of them) so far none this year.

@danj yes and they can be very hard to diagnose

True! The only sure way I've been able to tell is to weigh them the heaver one (a few oz. difference) is filled with the fluid.

댓글 달기

I have a MacBook Pro 13 early 2011 i7 with 8GB of DDR and a Samsung EVO 860 installed. It is running on APFS. It is fast and responsive with excellent scores on GeekBench.

At startup the temp spikes to 95c and the fan runs fast. This occurs without or with SMC operating.

After 20 seconds or so when loading is complete, the temp drops to 45-55C and as I type this the temp is showing 48c.

Is this a HDD cable, heat sink or temp sensor issue?

해당 답변은 도움이 되었습니까?

점수 0

댓글 1개:

How about upping the RAM if you can go to 16 GB and cleaning off some space on your SSD.

I often find people overload their SSD's as they bought too small a drive. Unlike an HDD SSD's need to move the data blocks around to even out the wear so a drive which has no or very little free space works harder to do this hence more heat and you wear out your SSD much sooner!

As a framework I recommend 1/3 free for the smaller SSD's ≤ 128 GB, 256 GB to 1 TB 1/4 free, 2 TB upward 1/8th.

Both of these actions will reduce your heat issue. I would also replace the HD SATA cable if you hadn't and I would use the 2012 version not the 2011 version as the cable was improved.

Then come back if you still have a concern after these upgrades.

댓글 달기

귀하의 답변을 추가하세요

Tom 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 7

30일 전: 20

전체 시간: 1,284