주요 콘텐츠로 건너뛰기

KitchenAid Dishwasher runs intermittently but doesn’t clean

Fills with water-wash cycle stops/starts for hours but not cleaning. Cancel-Drain works fine. I’ve replaced the sump and motor and the control board but still getting a 4-3 error, which is not showing up in any searches.

A lot comments mentioned the door actuator not making good contact with the door latch switch in this thread that describes the problem .

Whirlpool Dishwasher stops after filling with water

Model #KDTE104ESS4

Another clue-burnt wires leading to control board (disconnected during control board installation)

Block Image

Update (11/08/2018)

Thanks for responding. Yes filter is clean.

Block Image

I don’t think the sprayer arms are moving any water. The tub fills and sometimes sounds like it’s working but top rack not wet.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 3
댓글 8개

Did you check the float in the bottom right corner? If it’s stuck it won’t let the tub fill up properly.

Yes float is functional.

When I replaced the control board I noticed the outside of the panel wires that go the control board look burnt. Should/can I replace those?

is the error definitely 4-3?

Yes it’s 4-3.

댓글 3개 더보기

댓글 달기

답변 3개

가장 유용한 답변

Tying threads together for this issue, I have a potential solution here: Whirlpool Dishwasher stops after filling with water

해당 답변은 도움이 되었습니까?

점수 1
댓글 달기

Have you checked the filter inside the unit? Page 16 and 17.

Also can you post a photo of your drain tube? The drain tube needs sufficient fall to prevent dirty water from backfilling the unit.

해당 답변은 도움이 되었습니까?

점수 0

댓글 7개:

Yes it’s 4-3.

I finally found an answer. The problem is the Circulation pump. Apparently this is different from the drain pump. If you replace the circulation pump you should be good to go.

Also I hear this part is expensive. Good luck brother.

I'm having this same issue. Circ pump quit. Replaced with new assembly. Started it up and now it just keeps cutting on and off. I bet this is what caused the original motor to fail. Any suggestions?

I am having the same issue. Self test shows a code of 4-3 indicating a problem with the wash pump circuit but both the pump and the control board have been replaced. Still has the same problem. The pump starts for only about 2 seconds and then shuts off. It seems to repeat that several times but the wash pump never run for more than 2 seconds.

See the post I linked below. Mine also would work off and on and it was a loose connection.

댓글 2개 더보기

댓글 달기

The motor could still be faulty for a couple reasons.

I'll explain:

The short answer is that the all the moving parts of the main pump motor are under water and the magnetic armature shaft is held in place by two graphite bushings.

Yeah, the bushings are made of pencil lead. You're getting graphite dust in your rinse water.

These wear out and the magnetic impeller shaft starts wobbling. Wobbling makes the bushing wear out even faster.

Eventually the shaft just sticks to the side and the motor shuts down.

Another problem could be that the replacement motor is the wrong one but it still fits the dishwasher. They are larger than the original and put too much of an electrical load on the circuit board.

Yep , your dishwasher is quiet partly due to having a weak energy star motor... when it works... I don't see how running for 3 hours is saving energy when it could prolly wash it all clean in 20min with a powerful motor.

Just a bad design and they gouge you with poorly made replacements.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

Curtis 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 2

7일 전: 13

30일 전: 69

전체 시간: 5,458