Skip to main content

2011년 하반기 모델, A1278 / 2.4 GHz i5 또는 2.8GHz i7 프로세서.

506 질문 전체 보기

Is my SMC dead?

Hello everyone,

My late 2011 MacBook Pro has come to an end. Even if right now is perfectly working when plugged to the charger.

After shutting down, due to a completely discharged battery, I plugged the MagSafe in and try to turn it on. Nothing happened even after resetting PRAM and SMC.

I unplugged and plugged the battery back in and it magically turned on, but the battery wouldn’t charge even if the charger was plugged in. Strangely the battery was discharging even with the charger on.

Once the battery discharged completely, the system shows a crossed battery symbol. Now battery is not recognized and in order to turn on I have to do the reset SMC procedure.

During this procedure the MagSafe charger remains Green without changing to Amber.

I also downloaded MacsFan control and the result is that “No fans detected on this computer”.

Another strange behaviour, when the MagSafe charger is plugged in and show a bright Green, if I unplug the charger the system shuts down immediately. If instead the charger show a lower green light and I unplug the charger the mac continues to stay on, so I guess the battery is still alive.

Is my SMC dead? Is there any way via terminal to detect if it working or not? Shall I try and replace the SMC?

I have seen from this similar post: Cooling Fan running constantly/not detected by Fan Control Apps. There someone suggested a PRAM battery replacement, Can this be applied to my late 2011 model?

Thanks a lot for spending your time reading this. I hope someone can give me a solution for this problem!

Cheers

Block Image

Block Image

Block Image

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

How about installing this app CoconutBattery paste a snapshot of the main window so we can see whats happening with both your battery & SMC logic. Adding images to an existing question

의 답변

thank you Dan,

just added the picture!

의 답변

의견 추가하세요

맥북 배터리 수리 키트

기본 가격은 $69.99

Buy Now

맥북 배터리 수리 키트

기본 가격은 $69.99

Buy Now

3개의 답변

가장 유용한 답변

It sounds like you have a faulty charging circuit from your description and the basic troubleshooting, but unless we plug into your Mac a different known good battery there’s no way to tell, you might simply have a faulty battery that can extend its fault to the logic board when plugged in place. If you had a SMC issue it would probably give troubles even with battery unplugged but if I understand right without battery the Mac runs fine. SMC don’t go bad so often unless there’s water damage and from a technical point of you replacing it without testing makes no sense. There’s no Pram battery in your Pro model.

해당 답변은 도움이 되었습니까?

점수 4

댓글:

Thank you arbaman!

I actually had the chance of testing with another battery which worked fine in another mac but it wouldn't charge in mine. So i guess it is a fault in the charging circuit.

I might have a deeper understanding by a little research and see how to replace, if possible, the charging circuit.

what about the constant fan on? will be fixed too once i solve the alimentation problem?

Thanks a lot

의 답변

@lumusca Hard to tell for sure, but there are chances the fan misbehaviour could be related to the main problem. I wouldn't worry about that though, if you manage to fix the charging, fan can also be controlled by a third party utility.

의 답변

Did you also run TG Pro on your system? What does it show?

I'm suspecting you have liquid damage. How about pulling the logic board out and do a full inspection looking for corrosion or staining. MacBook Pro 13" Unibody Late 2011 Logic Board Replacement If you see something off post a good pic so we can see it.

Use a small soft paint brush to scrub the logic board and other parts of the dust build up and use a can of can'ed air to blow it out.

의 답변

Yes i have tried the TG Pro but again no fan is detected and I can't control it manually. I will have a closer look to the logic board and see if there are any element of water damage.

Thanks again!

의 답변

@lumusca - Can you post a snapshot of the TG PRO'S main window so we can see the other sensors.

의 답변

1에 댓글 더 나타내기

의견 추가하세요

If PPBUS Voltage is 12.56~ and you have 3.42V on SMC RESET unlikely. If PPBUS voltage is 12.23~ check SMC RESET voltage. You should have 3.4v. If you dont, the SMC may have crap under it or the Reset chip isnt working.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Luca - Yes your SMC logic has issues! You really need to take your logic board out to inspect things. If find this is a bit much for you, then your only option is just replace the logic board your self or bring your system to someone who has the skills and tools to diagnose things at the component level.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

luca 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 4

지난 7일: 5

지난 30일: 18

전체 시간: 93