Dead Z5 Compact only gets detected as QHSUSB__BULK

My 2 year old Z5c (E5823) died while updating some app, and doesn’t show any signs of life since then. Connecting the charger doesn’t turn on LED indicator, but it does consume about 0.90A (tested with a USB meter).

I have tried all different reset procedures, and only the first time I tried the 2-minute reset did it vibrate once or twice. Since then it doesn’t ever vibrate either. If I don’t press the power button before connecting to Linux, then it gets detected as QHSUSB__BULK (Manufacturer: Qualcomm CDMA Technologies MSM) only. However, if I reconnect it , then it gives a USB error related to "USB power limit exceeded” :

device descriptor read/64, error -110

I then need to either disconnect the batter or press the off button next to Sim. My first priority is to recover its data (the phone was encrypted). And if possible, fix it. The phone wasn’t available in my country and I had bought it from abroad, thus local Sony care or a third party repair centre isn’t an option.

I will be buying any parts and repairing myself as I have experience with electronics repair, but I need some help as I can’t even find schematics for the phone or information about JTAG connectivity for it. How can I confirm the issue is a hard brick and not something related to hardware, like power module/IC? Any other advice to further diagnose or fix it will be greatly appreciated. And if someone can send me its full service manual or schematics (Not the shorter mechanical / electrical troubleshooting guide) then that would be even better.

Thank you very much.

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요