Why is my battery not charging or recognized?

My ACER Iconia 10” tab mod B3-A40 often get a battery overheating msg ask to "remove battery". In time would random abruptly turn off while in use. Then frequency turn offs increased & only able use while was plugged in. In more time inoperable. Turned off and would boot. I bought a brand new battery from an auth ACER parts dealer. Still not work. While plugged red light below camera lens lit up but not boot. I charged for hours & nothing. Somehow by tinkering it turned on, showed low battery 3% & when plugged in the battery icon showed it was in charge mode (with lightening bolt) but went from 3% to 2% with constant warning battery low to plug in. By simple observation microusb charge port seems ok not loose. My battery is not accepting a charge or it is not recognizing that a battery is plugged in as I would have assumed that a new factory battery would have some pre-charge in it if not full. And of course my question is why? or what could be the possible reasons? Is it the charge port or circuit board stuff?

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

Have you tried charging your tablet with a 2000 mAh charger? Charging with low amp adapters may not charge your battery efficiently.

의견 추가하세요