Controller Triggers not responding

I took apart my Xbox One controller to resolder vibration motors and replace the plastic analog stick pieces. Put it together and everything works fine except for the triggers. In Win 10, there is an app from the store that allows you to test Xbox One controllers, so I tried that and the triggers always stay at 100% no matter how it's pushed or not. The magnets weren't touched at all and no matter if I try to get in between the magnets or try to slightly push the trigger to the side, no response at all.

The built in windows gamepad configuration's calibration showed the Z axis as both 50% and unchanging. I tried uninstalling and reinstalling the controller but that didn't work either. I doubt it's a fault with magnet misalignment because not even a little change in the position of the magnets (I did not touch them, only the plastic trigger part) would produce any sort of feedback. The trigger motors work fine though.

Any help appreciated. :)

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기