주요 콘텐츠로 건너뛰기

1.6 또는 1.8 GHz dual-core 프로세서, 2 GB 또는 4 GB SDRAM, 64 GB 또는 128 GB SSD

187 질문 전체 보기

Power supply issues after battery replacement.

Alright fellow Fixers! I am losing sleep over this issue with a Mid-2011 MacBook Air I’m repairing for a friend.

Back story: I’ve been working on electronics for years and have torn down and repaired just about every known Apple product and have never had an issue like this!

The problem:

  • MBA had water damage and just turned off and left for a few years. The keyboard and trackpad would no longer function and would only power on when connected to AC. I figured the battery was bad as it sat for years without charging but the MagSafe adapter light is green and the computer recognizes the battery is bad (warning on the desktop) *THIS IS IMPORTANT*

fast forward, I end up troubleshooting the keyboard/trackpad issue and narrow it down to the trackpad had failed and easily replaced it with a new one to my relief the keyboard and trackpad work flawlessly again!

Next I figured the batteries bad so I’ll order a new one (A1406) and install it to have this sleek piece of human engineering back purring. I get the new battery installed and go to plug it in to see the MagSafe light is not coming on. I power up the laptop on the new battery and let it sit thinking it’ll figure it out shortly. NOPE! I reset the PRAM and SMC hoping it’s a calibration/Apple quirk and get NOTHING. I disconnect and reconnect the battery, NOPE, I disconnect ALL cables and thoroughly clean and reconnect. Nope! I’m thinking at this point the MagSafe power supply is bad and decide to try installing the old battery back in and plug in the power cord to see surprisingly the green light comes on!

What could be causing the laptop to work and power on with the new battery but not work with the MagSafe AND have the MagSafe adapter work but not charge with the original battery?!?

My hair is graying as we speak! Thanks in advance, community!

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기

답변 1개

선택된 해법

I seem to have “fixed” the issue! I decided to attempt to trick the MLB by disconnecting the battery and plugging in the MagSafe adapter. Once it turned green I carefully connected the new battery and VOILA! The adapter turned orange and I’m currently charging the battery! We’ll see if it works out. Still curious why I had this issue and if there’s a different solution as I don’t like connecting a battery or messing around the components while I have power applied.

해당 답변은 도움이 되었습니까?

점수 0

댓글:

Apparently it only fixed it for that instance. Once I unplugged the adapter and tried to plug it back in I ended up back at square one!

댓글 달기

귀하의 답변을 추가하세요

BrentTaylorBA 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 1

30일 전: 2

전체 시간: 36