메인 컨텐츠로 가기

2010년 중반기 모델 A1278 / 2.4 or 2.66 GHz Core 2 Duo 프로세서

861 질문 전체 보기

Weird booting inconsistencies, PRAM reset not working

This Ebay purchase has a rich variety of unsatisfying boot up scenarios: Sometimes it boots very slowly with the HDD disc with which it came, sometimes it shows me the EFI lock asking for a password, sometimes only grey screen. After a few painfully slow boots I exchanged the HDD for a good SSD, I tried SMC reset, responded OK, light change on mag. Then I tried PRAM reset, which it flatly refused to participate in. Just now it chimed, fans on full speed, question mark.I tried booting of external drives, still no luck, just grey screen. Just now I put in the slow HDD it came with, and it boots, ever so slooooowly.

Then I put in another known good SSD, and question mark folder again….

My question is: WTF? And how can I restore the PRAM reset function?

답변함! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

It consistently now boots of the HDD it came with, but refuses so two SSD drives with known good function. How can this be. And still no PRAM reset possible...

의 답변

What are the make and models of the SSD's you are using?

의 답변

Thanks for responding, Dan. The SSDs I am using are my usual Kingston A400 120 GB and 240GB, which I have been using on all my 2009-2012 MBP upgrades now for a while, and successfully. The specific ones here are booting fine in other 2010 24.Ghz MBPs. I just did a whole software update hoping to resolve the PRAM isue, but no cigar …yet. I even checked the keyboard functions for p, r, and option, all OK

의 답변

OK both the Kingston A400 SSD's are listed as supporting both SATA II (3.0 GB/s) & SATA III (6.0 GB/s) so that removes that issue as your 2009 can only support SATA II drives.

의 답변

Yes, the A400s do work well in those machines. I tried some more boot patterns, such as Safe mode (shift) and command R , and none of the commands register, it just goes to the apple logo, or in case of Com/R is went to the locked EFI screen. Is it not called SPI mode when the computer responds to commands before the OS loads? It seems that mode has issues. Any clues?

의 답변

1에 댓글 더 나타내기

코멘트 추가

안드로이드 수리 키트

새 스크린 혹은 배터리는 단 하나의 키트로 충분합니다.

지금 장보기

안드로이드 수리 키트

새 스크린 혹은 배터리는 단 하나의 키트로 충분합니다.

지금 장보기

2개의 답변

선택된 솔루션

Did you make sure the Startup disk setting in system preferences is correctly set?

Open:

Block Image

Then set it:

Block Image

What is the macOS version you are running on it?

이 답글이 도움이 되었나요?

점수 2

댓글:

@danj Dan, how does one set the start up disc settings correctly?

의 답변

@jurgenkoppen - I've added the details in my answer.

의 답변

Thank you Dan. I think I will deal with the Bios chip and see if that will resolve the issue. According to the help I received here from Ben, the issue is with that Bios chip, : the fact that the machine is locked via Bios to the HDD it came with.

의 답변

@jurgenkoppen - I would first check the Startup Disk as often I've seen a system which can't tell which volume to boot from show a padlock and then other times boot up with no issue or just slow. Which is exactly what you are seeing here.

It's a helluva easier than fussing with soldering chips.

If you encountered the padlock every time then I would re-set the EFI. There are tools which don't require altering the chip. If you want to know email me.

의 답변

@danj , OK, I obviously can try what you suggest first. So I suppose I boot up via the existing internal HDD running High Sierra ( the only one that can boot so far), but I will have another bootable SSD with a fresh Sierra install connected. Once I am booted, I go to Disc Utilities and tell the machine via Start Up Disc to boot off the external SSD. Am I understanding this correctly? And yes, I always want to know whatever tools are available to keep this units on the road...

의 답변

4에 댓글 더 나타내기

코멘트 추가

If you do see the padlock on the middle of the screen and this MacBook was bought second hand I would not spend any more time fixing it as removing the EFI BIOS firmware password requires either knowing the password or changing out the BIOS chip with another one that is clean.

Without getting past the EFI lock there is no way to use the MacBook.

Well if it does boot and let you login with the original drive you'd be tied to that drive and the MacBook would turn into a paperweight if that drive or OS fails.

이 답글이 도움이 되었나요?

점수 1

댓글:

Thank you Ben. The weird thing is , though, that it shows the padlock only sometimes. When I boot again, as long as I have the original (slow) HDD in it, it does boot up . However, I do recognize that the bios chip is implicated. I have seen them on Ebay, and, as a Louis Rossman follower, I do have the gear to solder on a simple chip....albeit my skill is still a bit bumpy (Only successful so far with simple big caps). Do you know about the bios chips on Ebay, and would that solve the issue and then allow me to do the PRAM reset and install a SSD? https://www.ebay.ca/itm/BIOS-EFI-firmwar...

의 답변

With the padlock EFI lock it restricts the MacBook to only allowing it to boot on the original hard drive.

The MacBook may have other underlying issues than the BIOS chip but that chip can be taken from another donor board for example another 13" 2010 board and it will work from there without an EFI lock provided it wasn't also locked too.

As long as you have a soldering iron and a hot air rework station replacing the chip is doable with some experience.

Fans going full speed indicate a temperature sensor problem. Could be a thermistor that is not being read properly on the logic board, liquid damage is a common cause of this. The throttling slow speed is also related to the above too for sensors and sadly also can be caused by hard drive cable going had but unlikely in this case.

A damaged trackpad or trackpad cable can cause this too.

의 답변

@benjamen50 Wow, thank you so much for this detailed answer, Ben. This problem and your answer illuminated a whole raft of functions for me, which previously were still cloudy in my (lack of) understanding. I will positively solder on another Bios chip, I ordered it already. I am sure that after replacing the EFI chips' pads with leaded solder I will be able to get the new one to stick using my hot air station. I can run HW sensor program to find out where the thermal issues reside...This all seems doable, because this chip is not so tiny that it beyond my scope. You rock!

의 답변

코멘트 추가

답변 추가

Jurgen 이(가) 영원히 고마워 할 것입니다.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 16

All Time: 64