MacBook Pro 13" mid 2014 stuck in boot Apple logo


I have a Macbook Pro 13” inch a1502 from mid 2014. The computer manages to boot up, and display an Apple logo without any progress bar. However, once it got to that stage, the computer got suck and does not boot to the OS.

I also notice something quite strange, if the screen is open and I plug in the computer, the computer will automatically start up without pressing the power button.

Here is what I have tried, and the results of each attempt

  • I tried resetting the SMC. After resetting the SMC, the computer will turn on by itself, and display an Apple logo on a black background
  • I tried resetting PRAM. After resetting the PRAM, and when I turn on the computer, the screen will turn on but no Apple Logo
  • I tried pressing the [D] key, to invoke Apple’s diagnostic tool. The result is, the computer will turn on, but after the initial chime, the speaker will make a noise, and the screen remains black
  • I tried pressing the [command] + [R] key to try and get to the recover mode. The result is the same as pressing the D key.

Any suggestions on what should I try, or what is wrong with the computer?

Thank you

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기