주요 콘텐츠로 건너뛰기

The Xbox One Model 1698 Wireless Controller was released by Microsoft in 2015 alongside the Model 1697 controller. This controller is similar to the Model 1697 with internal modifications. It has more features than a basic controller, such as, removable thumbsticks and metal D-Pad buttons. The controller is primarily designed for console use, but is PC compatible.

62 질문 전체 보기

RARE bug/defect: left stick input gets linked to right trigger

I have only found two other documented threads (both locked) that mention this weird bug. Essentially, when the left analog registers the maximum value or near maximum value for “forward” with a simultaneous depression of the stick (forward and clicked down to sprint/tac sprint in games ex: Modern Warfare) there is a simultaneous registration for the depression or perhaps depressions (many pulls at an extremely rapid rate) of the right trigger.

Basically I received this controller lightly used when I bought this guys Xbox one X. No issues whatsoever except the grips began to come undone and I eventually replaced the side panels. Two months later I decide to get an Elite II because I’m a sucker. Elite II has left stick problems of its own so I sent it back to Microsoft and pulled out the Elite I to use in the interim. Not 12 hours into my Elite-II absent depression I started to notice the issue. Thought it was latency or maybe something breaking because of the update that was being pushed in the coming days. Then I thought I had set the hair triggers “too thin” and that my grip on the device was unintentionally bringing the trigger in close enough to register a pull. I set the RT deadzone deep into the trigger well but the problem persisted. I confirmed this in the accessories app. After it really got bad (trigger firing without depressing the left stick at all) I began looking online.

I will do my best do describe what happens in game. I hope this will provide necessary details of the end result so that we can trace the issue back to something in the control itself.

The bug/defect’s manifestation on screen occurs when trying to run. It causes failure in the running movement’s performance while simultaneously resulting in unwanted rounds being discharged. What’s interesting is that the weapon is stuck between its running animation position and its “sprint to fire” position. If you are unfamiliar with Modern Warfare understand that is impossible to fire a weapon while running. If sprinting is interrupted by the intentional act of engaging targets the character model will stop running as soon as the trigger is pulled but that pull will not result in the weapon being fired until the character has slowed to a default “shoot while moving” pace. It is possible for rounds to exit the weapon in the frames between the cessation of sprinting and the point where one of 4 possible firing positions is achieved but they end up in the ground or on a diagonal way from the character model’s front because the muzzle was previously pointed at the ground. The motion of “stopping a run to engage” is not holdable firing position because the character model would be forever “stopping his/her forward motion.” while “raising the weapon to hip or shoulder fire.” This is simply impossible. Thus, when this bug occurs it almost suspends the character model in that “coming to a stop” stance as the barrel toggles rapidly between a "low ready run" and snapping up to where the barrel would be pointing during an intentional engagement (this is mostly input data collected from the right analog). The gun wont fire when it snaps up the first time but if the left analog stays engaged it will sometimes fire a round or two when it snaps back down. I have resorted to walking as fast as I can around the map to avoid this issue but am then faced with the random RT registrations that come without the depression of the left analog. This just means I’m walking with the gun out in front of me and it’ll suddenly fire. Sometimes it’ll still fire a few rounds after I take my thumb off the left analog and let it come back to 0,0.

Seems very rare. I have tried all suggested solutions (swapping out different thumb stick types worked for for a few hours but the issue came back as worse as it was before even with constant recycling of a myriad of thumb-stick combos and layouts. Same thing the next day- was fine for a few hours but then awful. Almost like the controller needs to cool down or forget what left stick forward feels like in order to work again…

I don’t know much about chips and boards but I understand the basics and I understand wiring. This controller isn’t “expendable” to the point where I would gut it out of general curiosity but I’m really impatient and don’t know how long MS will take to send the Elite II back. However, there is no way I’ll send this in for payed service at MS because the cost is not worth the trouble. That BEING SAID- I’m deeply bothered by the fact that both threads documenting this issue were archived due to lack of progress and/or lack of OPs ‘responses despite other users confirming numerous cases of the bug. Deeply bothered.

So I’m going to open it up right now and look for dirt or anything clearly out of place but aside from that I’m stuck. I hope someone knows how to fix this or is also weirdly bothered by its lack of resolution and would like to use their knowledge of the Elite I’s internals to help me poke at a dismantled controller correctly. I can’t sleep thinking about how OP never came back to his post. Please help.

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 8
댓글 19개

I'm experiencing something very similar but essentially reversed from what you've explained. With my controller, it is the right trigger that activates a reading of up on the left analog stick and it does this in a rapid fire manner. Reminiscent of a light bulb that is shorting out . Any ideas as to how to solve this issue?

Hey mate, I'm sorry you're having an issue too. It's truly a mind boggler. I took apart the controller and visually checked out the soldering work but couldn't determine the source of the problem. I've been a little busy with school but my next step was to try to find a schematic for the controller to see where exactly the streams could be crossing so to speak. I'm in a little bit over my head haha. But I want to get to the bottom of this. Interesting that you are experiencing a reverse of my issue. Hopefully someone with more knowledge can weigh in. Best of luck.

Hi mate, I'm glad you've opened this thread for discussion because I have had the exact same issue and have retired my elite 1 to the shelf. From my dissections and experimentations I have found that the chip on the right hand side of the controller on the joystick motherboard, when firmly pressed with external pressure i.e tightening the screws in that region or firmly pressing with a hand, it does work fine with no RT trigger when moving the left stick. I have not yet done this but I plan on reflowing the chip to see if that makes any difference but worth telling you as I too am in the exact same boat

Hi. I've been having this issue too, and I have been unable to find a proper solution. It's been extremely frustrating.

Whenever i pull my right analog stick either to the left or downwards, it triggers the left trigger. I confirmed this when i went to settings and ran one of the button tests. It’s not too bad it’s just inconvenient at times

댓글 14개 더보기

댓글 달기

답변 5개

선택된 답변

The only solution I have found after encountering this issue was the apply pressure to the CPU on the motherboard which allows the controller to work properly. Perhaps a reflow of the CPU or reball could fix the issue otherwise an upper motherboard PCB replacement would be needed.

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:

Where is the cpu exactly?

댓글 달기
가장 유용한 답변

For anyone looking for an answer, I've discovered that it's the screw on the main board that holds the left trigger that's causing the problem, it must have come loose during use (I've been using this controller for 2 years). By tightening it, the problem is gone.

해당 답변은 도움이 되었습니까?

점수 6

댓글 3개:

Brilliant advice mine now works saved me getting a new pad cheers

thank you <3

Where is the screw on the main board?

댓글 달기

Maybe the cables got mixed up… Look for a teardown video. I don’t know much about Xbox though..

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

2 solutions. check if your controller has updates profile and system >>>> settings >>>> devices and connections >>>> accessories >>>> bottom left button •••

another solution is to restore default controls.

profile and system >>>> settings >>>> accessibility >>>> controller >>>> button mapping >>>> restore to default.

if none of these work, buy a new controller. or just find out because theres no possible way…

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:

I know this is an old thread, but I have the same issue on PC sometimes, and I know it is not my controllers, I think for me, my issue stems from my camera interfering with the controller firmware or connection somehow. All I know is when I unplug my camera and restart the game (or sometimes my PC) the issue resolves itself. So I would check if any other peripherals are interfering with your controller.

Hi im on ps4 and this happened and idk what to do

댓글 달기

The only way I know how to "fix" it is to ink the controller whenever it does it, but it only fixes it temporarily

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

Jack Kessler 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 28

7일 전: 185

30일 전: 815

전체 시간: 31,724