Problems booting, discovered damaged ethernet port.

I have a iMac 27" from mid to late 2011.

Reported that the screen went white and flashed rapidly and wouldn't boot up. Reset the pram, and booted into recovery to use disc utility to repair the drive. Restarted and it worked fine. As soon as I loaded a web page the screen rapidly flashed white, then to a grey, then brown. Forced shutdown, was able to load into recovery after several attempts and did another disk repair. Unable to boot it up since. Recovery mode using cmmd+R doesn't want to load. I've tried internet recovery mode and have gotten past the first loading bar with the spinning globe, onto the next loading bar and now the white screen of death. Screen has been like this for 30 minutes at least.

The ethernet port on the Mac has been damaged since January this year when the cable was forced into the port, causing pins to bend and cable to be lodged. Cable is removed and replaced, now using a USB adapter.

Because of the time of the damage, I was thinking I needed to reinstall the OS, which is fine. Other thoughts are a damaged logic board and now possibly a damaged hard drive.

The imac belongs to my in-laws and I rarely visit them so what exactly caused this problem, I have no idea.

Any ideas of what to try or what needs replacing?

Thanks!

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

Can you post some pics so we can see the damage clearly with the Ethernet port.

Are you able to boot up and run the onboard diagnostics? Restart and press the D key. If you are able to did you get any errors?

Reference: Mac startup key combinations

댓글 달기