Power LED ON then turned off after few seconds.

I have an Asus P2540UB (or a PRO554) i5 version. The battery led turns ON when I plug the AC charger. When I tried to power on, the power LED turned ON followed by the WIFI led then after few seconds it power off. NO display indication, NO fan spinning, NOR disk led indication.

I already tried some troubleshooting tips online like,

  • Removing the AC adapter and battery then press and hold the power button for 40 secs. Then connecting AC adapter and battery then power on. DID NOT WORK
  • Removing CMOS battery, AC adapter, and battery for 40 mins to drain residual power to reset bios. DID NOT WORK
  • Some odd tips like, save bios file (nameofbiosupdate.bin) on formatted fat32 USB. plugging it then on power ON, button smash CTRL+R. They say this will trigger bios recovery. DID NOT WORK.

I suspect that it is bios corruption but I’m still waiting for the motherboard tester and bios chip programmer I bought online.

While I have yet to know the cause, I give this forum a try if someone has a similar problem and proposed a solution to this.

Update: October 15, 2021

Trying to Flash BIOS

Block Image

I first downloaded the bios file from Asus support. Then I extract it. After that, I followed this tutorial on how to extract the bin file.

https://www.youtube.com/watch?v=4ibM26mr...

Then I use Asprogrammer to flash the bios, but before proceeding, I create a backup file by reading the content of the bios chip and save it. After that, I flashed the new bios file. After the verification, I connect the power supply and turn on the device. The power led didn’t turn on this time. So, I reflashed the bios using the old backup file. The power led turned on but still turned off after few seconds. Now I conclude that the problem might not be the bios.

I suspect it’s a power rail problem.

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요