Xbox Elite Controller disconnects when using official battery pack

First of all need to apologize for my English, its not my native language. I will try to describe the situation as I can in every detail.

Probably the issue is completely my fault. Yesterday tried to clean sticky left trigger that annoyed me for ages, used alcohol. Luckily the trigger problem was resolved in seconds, but after a short while the main problem appeared.

After cleaning I put official battery pack back and Xbox button started randomly flashing, next I removed the battery pack and waited about 30 mins in hopes that alcohol remains fully dry. Unfortunately after the controller found the console and paired it turned off making strange buzzing noise. I waited a bit more and even tried to use drier, but these pitiful attempts have led nowhere.

Later I removed the battery pack and connected controller directly to the console by cable and found out that many buttons were pressed by themselves, and the sticks behaved the same. At that moment I decided to disassemble the controller and clean it. Managed to did it without further unfortunate consequences, tried to clean it as good as I can and then assembled the controller again. Cleaning solved the problems with buttons and sticks, but the main issue remained, the controller disconnects when using official battery pack right after connecting to Xbox or PC (yes, i tried on PC too).

Strange but the controller works perfectly by cable OR with regular batteries, as soon as I put official battery pack it disconnects after pairing in 4-5 seconds.

I even tried to reflow the solder of battery connectors. This action as well did nothing. The controller works and fully operational, the only problem is disconnect with official battery pack.

Before you suggest that the problem lies in the official battery pack… I put it in another controller to test and it works perfectly.

I will attach photos of both motherboards in case some of you can spot the problem immediately.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Close up

Block Image

Block Image

Block Image

Block Image

I completely lost at this point and don’t know what to do.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1

댓글 16개:

Hi, Try to measure continuity-resistance between the pins of the battery connector (V+ and GND). It almost seems that there is some partial short between the pins or the battery circuit...

@honakrisi thanks so much for your answer. Sorry, but I'm no so knowledgeable when it comes to measuring. If there is a short so what can I do?

Plus another problem appeared out of nowhere. B button keeps randomly pressing on its own... :( And the controller making buzzing noise non stop.

Can you upload a close-up photo of the battery connectroon both sides, please? Are the solder joints touching?

The B button's switch (SW 3) looks fine so it will be something else on that line that is shorting it therefore acting as making a connection...

Also on the fist picture R45 and D1 seem like missin comonents. I don't have any donor boards to see if they are factory missing or actually knocked off... What did you reflow the pins with? Soldering iron or hot air?

@honakrisi I updated the question, added close up photos.

I did reflow with soldering iron. R45 and D1 was empty originally.

댓글 11개 더보기

댓글 달기