주요 콘텐츠로 건너뛰기

iPhone xs water damage, boot loop and now a black screen

Hi all, would really appreciate some help here.

My phone fell in the sink the other day when the tap was running, I took the phone out within a second or so and it was never submerged. A message came up saying that faceid had been disabled but apart from that the phone continued working as normal and I never really thought anything of it, as apple advertises the phone as being water resistant. I charged the phone as normal that night and it was still working in the morning but crashed after about 2 mins of use and was then stuck in a boot loop, Apple logo, green flash, black screen, repeat.

I looked online to try and find out what the issue was whilst the phone was drying and it seemed likely that it was a proximity sensor/ear piece shorting issue that was causing the reboot loop. A day or so later I opened up the phone to see if I could disconnect the proximity sensor and there was no obvious sign of any water damage - I disconnected the battery, then the proximity sensor, reconnected the battery and powered the phone but there was no response at all, just a black screen.

I then tried to connect to iTunes to see if it was just a screen error and even though the phone vibrated when the lightning lead was plugged in, iTunes didn’t recognise the phone and neither did the finder. I reconnected the proximity sensor, pressed the power button and there was still no response on the screen. I took the phone to a dark room and could see two very faint white lines going from top to bottom of the phone (like racing stripes), then a slight flash, black screen, racing stripes, repeat - so I presume it was stuck in a reboot loop like it was before.

Today I tried again to see if I could work out what the issue was and disconnected the proximity sensor, booted the phone, the display was still black but the phone was vibrating when the charging cable was plugged in and vibrating when the power & volume up buttons were pressed (as if the power up slider was appearing). I tried to connect to iTunes again but had no luck, I then tried to put it into recovery mode which worked and gave me the option to update/restore, although the screen was still blank.

Weirdly the last time the phone connected to find my iPhone was during/after my initial repair (don’t know at exactly which point), this and the vibrations are giving me hope that there’s still some life left in my phone but I’m stumped with what’s causing the issue.

At this point I’m not too bothered about having a working phone, I just want to recover the data as there are pictures etc on there that are very important to me, which haven’t been backed up (stupid I know).

Any help/suggestions would be really appreciated.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

If your seeing some life from the screen then the screen could be damaged, try a replacement before anything else

Thank you @tech_ni is it strange that it's not connecting to iTunes if it's just the screen that's broken? I'm not seeing life from the screen but the phone is definitely on, it vibrates when silent mode is clicked on etc.

Maybe need to let the phone trust the computer

All of you are wrong sadly. Posting the correct info

댓글 달기

답변 1개

Ok so the issue you’re having is the Front Facing flex that hosts the Prox sensor and ALS has water damage to the pads underneath the components. You will need to remove both components and apply fresh solder and clean the damaged pads and put the items on a new flex. This is famous for boot looping and dead phones.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

Yahut 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 8

30일 전: 19

전체 시간: 87