iMac not booting after reassembling

Hi, my iMac mid 2010 wont boot I was changing the SSD cable on my system. Everything was OK. Had no issues beside the SSD cable broken after replacement.

Took out the logic board for better access so I wont damage the mother board And now After reassembling my iMac won't boot.

The screen is black, when I plug it into the wall without me pushing the power button it automatically turns on, then after 20 seconds or so, if i hold the power button for 15 seconds it will shut off The diagnostic lights 1 and 2 light up on the logic board fans run

But the third one won't light up and screen is black or wont chime or boot. I know the third light on the logic board is for graphic card or suggests that the logic board has issues But I'm 100 percent sure there is nothing wrong with graphics card and logicboard

My ram is OK & my cpu is OK, I've done SMC reset, Changed the PRAM battery

PRAM/NVRAM has been reseted, basically everything that i have read so far on any forum has been done on it. I haven't seen a single person with my issue. Either they don't have any Diagnostic LED's on At least they hear the chime

Plz help me I'm at the point of giving up on this iMac

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1

댓글:

I followed the instructions when i was installing everything

I use to fix phones so i know how to work on boards

But this i cant fix

Everything is ok

All parts are ok

But the imac wont boot at all

Only led 1 and 2 light up on logicboard

댓글 달기