iPhone 5s iTunes restore problem "waiting for iPhone" (4013)

I have an iPhone 5s I suspect of possibly having a malfunctioning Tristar U2 IC.

I purchased the phone described as not charging and confirmed this with a USB ammeter when I received it.

I isolated the battery and charged it with a li-ion charger, plugged it back into the phone and the phone turned on. Strangely it now charges through USB so the charging problem seems to only be an issue when the battery is completely depleted.

I needed to restore the phone to remove the previous owners screen lock however after starting the process it hangs right at the start of the restore process when the progress bar appears on the iPhone screen and iTunes says "waiting for iPhone".

Having looked in Device Manager (in Windows) I can see the iPhone is not re-establishing a connection after being prepared for restore, the computer can not see it.

I've also tried iOS-OTA-Downgrader on Ubuntu as a different method to restore firmware and I encounter the same thing, when the progress bar appears on the phone the process hangs because the iPhone is not connecting.

Why is this happening? I presume it's something to do with the Tristar U2 IC but why does it prevent the iPhone connecting for the restore process when it connects to the computer without issue before getting to that point? What is actually happening with the connections for this to happen, does Tristar negotiate USB data connections?

(I've also tried restoring without the screen connections, and the cable remove/reinsertion at various points of the process which has worked for others.)

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글 1개:

could be tigris as i think it negotiates usb data

댓글 달기