Mouse is not Tracking anymore

The problem:

All of a sudden my Magic Mouse stopped tracking my movements (cursor). So here is what I have tried:

1. New batteries, twice

2. Remove mouse from the bluetooth, and readded it

3. Clean the lens... which worked for 2 minutes

4. Clean the lens... again worked for 2 minutes

5. Tried it on other devices, at other places but tracking wasn't doing anything

What it is doing:

1. Left-click

2. Right-click

3. Scrolling

4. Gestures

5. Swipe etc

So here I am, tearing down the Magic Mouse on a Friday night.

What my best guess is that my optical 'sensor' is broken or at least not getting all the contact it should get.

Does anybody have a keen eye, and could tell me what is wrong with it?

Thanks for taking a minute, hopefully anyone is able to help me out.

ps. I get the fact that my ribbon is a bit loosy, due to the fact that it took it apart.

Kind regards,


Block Image

Block Image

Block Image

Block Image

Block Image

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 6


Hi, Is it my imagination but in the first photo, the lower battery terminal looks more discoloured than the top terminal (cannot see the face of it though) also its' lower connection (as viewed) to the board looks suspect although if it is only to take the strain it is not a worry. I'm wondering if it is a power problem i.e. the lens not getting sufficient but good enough for the buttons

Dear Jay,

Thank you for the quick reply.

The bottom battery terminal is indeed discoloured and I tried to clean the stuff off, but sadly I couldn't get it any nicer looking (i.e. cleaner) then this.

The faces of the battery terminals are identical, and not discoloured as far as I can see.

Could you rephrase what you mean by:

"its' lower connection (as viewed) to the board looks suspect although if it is only to take the strain it is not a worry."

I dearly hope it is a power problem or a bad solder joint, since I cannot seem to find any place (online) where they sell Magic Mouse laser bulbs/optical sensors.

Kind regards,



Looking at the first photo you posted, to me it seems that the bottom battery terminal has two connections (two arms if you like) to the board. The lower one, up from the brass looking eyelet appears (and I can only magnify it very little) different from the next one up. It may be that it is just connected to the board and has no electrical connection and is only there to strengthen the battery terminal against the push of the battery when inserted. Hopefully that explains it a bit better.

Still not fixed :(

Anyone out there that can check my solder joints/points from the laser sensor? (Check picture)

Kind regards,


I'm having the same issue here, exactly as you described it. I'm in the middle of working on a deadline and my home workstation is now basically useless… I also don't see any residue / discoloration of the faces of the contacts, and I've tried it with other computers / batteries and the issue persists.

의견 추가하세요