메인 콘텐츠로 스킵하기

2016년 9월 16일 출시. Model 1660, 1778. GSM 또는 CDMA / 32, 128 또는 256 GB / 로즈 골드, 금색, 은색, 검정색, 칠흑색으로 제공됩니다.

1200 질문 전체 보기

Apple Pay not working - where is the antenna?

I replaced my backhousing of my iphone 7 as it had a huge scratch on the back.

Now everything works perfectly but the apple pay.. can someone point me where exactly the antenna is for the nfc?

The gps, celluer, bluetooth all work perfectly and i thought they all share the same antenna band at the top, but i think nfc needs something else connected as well..

The housing is probably not oem so the material could be causing this but does anybody have any suggestion on this?

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요

1개의 답변

가장 유용한 답변

Around the main camera, look for a flex cable that connects a screw post on the board to a screw post to the top bezel, usually stuck to the camera bracket as well.

해당 답변은 도움이 되었습니까?

점수 5

댓글:

Am I right in assuming it's pretty much in the same spot on the iPhone 6S?

의 답변

Slightly different, looks like the one on 7 wraps around the whole right side of the camera socket, instead of just a short cable.

의 답변

Thank you very much for the answer. You mean the strip that screwed with the top right screw on the logic board and wrapped around the camera to be screwed to the top right of the housing?

If that is the case, that looks like placed in perfectly to the logic board and the new housing. Can you think of the reason why this isn't working?

I will try to put the entire thing back to my original housing to check nothing is broken tonight.

의 답변

Check the screw holes and contact finger landing area on the housing, they have paint machined off intentionally to make them conductive. If the replacement housing did not machine off paint in this area, then the reception would be defective.

Also check the exact assembly sequence of the top right screw hole on the board. The spacer, screw hole, cable screw end and contact pad must be assembled correctly or the signal won't pass through. After assembly, you can use a multimeter to test if they can conduct power end to end.

의 답변

This is very helpful! Thank you, Tom. I just put everything back in the original housing and everthing seems like working perfectly.

I checked my replacement housing and yes, it has the painting covering the screw holes and etc. Although the multimeter confirmed the conductivity only when i check inside the screw holes, I guess that was not enough.. what do you think?

I used sandpaper to scrape the paint off so hopefully i will have it working soon! I will only get to try installing all later this week so i will update you hopefully without any more question :)

의 답변

4에 댓글 더 나타내기

의견 추가하세요

귀하의 답변을 추가하십시오

Firo 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 2

지난 7일: 14

지난 30일: 67

전체 시간: 1,477