Released September 25, 2015. Model A1688/A1633. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

1759 질문 전체 보기

No touch function after backlight repair (Advanced!)

Hi, this is my first question here.

I own a repair shop and do repairs on iPhone's for at last 3 years.

Now i got a iPhone 6s that drives me CRAZY!!!

A customer brought it in for a backlight damage, as always i checked the FL4211 for damage, none to bee seen also no burning, after i took of the CPU shield and the D4021 was a bit raised so i replaced it, after that the backlight came on and worked like a charm.

BUT, after the initial boot, the image on the screen was full of a pattern i have seen before, namely when you turn on a iPhone 6/6plus without the U2402 on. Vertical lines with some kind of checkered pattern.

I replaced 3 screens, cleaned the FPC, restored with latest os, nothing changed.

After i measured the "PP1V8_TOUCH_CONN" and here i found a open circuit, i made a strap on the "FL4209" and after that everything was in order with that line.

Still no touch function, i measured the following lines:


All of them give me a ~0.420V voltage drop to ground, no open circuit on any of them!

Also i mesured the "PP5V1_TOUCH_VDDH" when the phone was on and i got the 5.1V on that line.

I cannot understand what the problem is? Where am i missing something? There is no mechanical damage to the board, all SMD parts are in the right places.

Maybe someone has a ideea...

Thanks in advance.


답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

US$100.00 이상 또는 Pro Tech Toolkit을 포함한 모든 주문의 배송은 무료입니다!

상점 둘러보기

Ever fixed something? That’s Genius.

Share your repair story with #ImAGenius

We Are All Geniuses

Share your repair story with #ImAGenius

3개의 답변

선택된 해법

Have you checked the Chestnut circuit? Beyond the 5V1 line, there is also the PP5V7_MESON_AVDDH

& PN5V7_LCM_MESON_AVDDN. There is also the PP1V8_TOUCH (Fl4209) line which also powers the touch functionality.

I would also check the AP_TO_TOUCH_RESET_L line (FL4134). Then there is the LCM_TO_OWL_BSYNC line (FL4230). There are lot's of Touch lines on page 42 of the schematic.

해당 답변은 도움이 되었습니까?

점수 2
의견 추가하세요


I have done some iPhone board work but I still don't know much but I know what if you search up STS telecom on Youtube he does lots of these problems. It's worth having a look.

Hope that helped

해당 답변은 도움이 되었습니까?

점수 0


Thank you but still did not find a solution to my problem...

의 답변

의견 추가하세요

in my case i checked SPI_TOUCH_TO_AP_MISO and no value checked on another working board and there is a testpoint next to the cpu i could run a jumper from but my bord dont have value on the testpoint either so the last point is inside CPU so am stuck at this point

Block Image

해당 답변은 도움이 되었습니까?

점수 0


In my case in diode mode I get 0.001v = short to ground? I would reball CPU but it feels the CPU is shorted internally?

의 답변

의견 추가하세요

귀하의 답변을 추가하십시오

Dacian Bujor 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 1

지난 7일: 6

지난 30일: 34

전체 시간: 366