주요 콘텐츠로 건너뛰기

Released 2007, identified as Satellite A215-***** (several variations, ex: A215-S7437)

12 질문 전체 보기

Why are my USB ports not working?

My Toshiba Satellite A215 laptop has four USB ports, two on the left side and two on the right. The left side ports work fine, but as of last week neither of the right side ports work with any device. How can two ports fail at the same time, and how can I fix it?

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 92


Please tell us which Toshiba Satellite laptop you have (Model Number)

Also need to know which OS you have. Sounds like a device manager error :-)

Toshiba Satellite A215 w/ Vista OS thanks,turkey

toddfer, did you get it accomplished?:-)

having the same problem but none of my are working

21에 댓글 더 나타내기

의견 추가하세요

답변 10개

선택된 해법

First, remove your battery. Then, hold down the power button for 30 seconds or so. This discharges the capacitors and should get them working again.

해당 답변은 도움이 되었습니까?

점수 34


Dear Shadaab Khan

Removing the battery and holding down the power button for 30 seconds solved my problem :D

Thank you very much

Removing the battery and holding down the power button worked thank you :)

dev manager DISABLE AND RE ENABLE forces it to restat

Hi at first that instruction solved my problem twice but third time it wont work anymore. help thnks

This actually works! I plugged a smashed USB thumb drive into my Toshiba laptop hoping it would still be functional; both USB ports stopped working immediately. I tried every other method I could find with no success. This method solved my problem immediately! I don't know why this fix is not more widely mentioned. Thank you!

16에 댓글 더 나타내기

의견 추가하세요

toddfer, not sure about your computer user abilities and do not want to be insulting or anything, but go ahead and check this out first. If you have already tried this let me know so we can get it straightened out. Also, of course, check your computer with a good anti virus program and check for any malware that can mess with your sytem

Perform a system Restore using a restore point prior to the loss of the USB.

Then check these areas:

• The Device Manager

START | type dev man into the Start Search box | right-click on Deice Manager that appears up top | select Run as Administrator | look for any red/yellow flags - pay specific attention to the USB area.

Problem Reports and Solutions -

START | type wercon.exe into the Start Search box | right-click on wercon.exe that appears up top | select Run as Administrator | view "See Problems to Check".

• The Event Viewer -

START | type eventvwr into the Start Search box | right-click on eventvwr.exe that appears up top | select Run as Administrator | view the various logs starting with the Administrative logs.

• Reliability and Performance Monitor -

START | type perfmon into the Start Search box | right-click on perfmon that appears up top | select Run as Administrator | view both the Performance Monitor and the Reliability Monitor.

The other thing that you can try is to go to the control panel, select Sytem, select hardware click on Device manager and scroll to Universal serial bus controller and Right Click on the USB Root Hub and select uninstall, You might even have some that have a triangle on them identifying an error or even crossed out red. Delete all those. Once deleted a restart of Vista should find your USB ports and identify it as new hardware and install it as new hardware.USB is Plug-N-Play and Vista will find the drivers for you automatically.

If this does not resolve your issues, you may have to check the bios of your computer and see if it displays anything with the BIOS but try this first and get back to us...:) good luck

해당 답변은 도움이 되었습니까?

점수 10


dev manager click the icon with ! click disable.....click enable... forces it to start.. Masters degree computer egn

의견 추가하세요

I had a similar issue, the right hand side usb's of a customers laptop were not working as well as the DVD drive. I started with the DVD drive and removed upper and lower filters in the registry. This also fixed the usb's, I did not know however if this was a fluke. A few days later I had a similar job, but only the usb's were not working. I removed upper and lower filters and they started working fine.

To get to registry: Press the Windows Key + R. Type regedit into the "Open" line and press enter.

Expand "HKEY_LOCAL_MACHINE", then "SYSTEM", then "CurrentControlSet", then "Control" and finally expand "class". there should be a folder approximately ten down starting with "4D36E965" select this. Inside if you see any files with UpperFilter or LowerFilters delete them.

Restart your computer and hopefully they should be working.

I hope this helps.

해당 답변은 도움이 되었습니까?

점수 3


Worked for me. There is also a design fault where some part is located near the touch pad that effects sound and USB ports that cannot be fixed I believe. We have 3 Toshiba Satellites and all are effected. NEVER buy a Toshiba.

의견 추가하세요

This happened to my Satellite A665 a week ago, first noticed as intermittent random failure to charge my cell phone (i.e. failure even to put the charging symbol on the battery icon in its status bar), when it did charge from pure power type chargers. After reading the first answer above, I safely removed all USB devices (including the mouse; for the sake of purity, I used the touch pad, which I HATE, until the problem was resolved), used the Device Manager to uninstall both USB root hubs, shut down the computer, removed the power plug and battery, and held down the power button for 30 seconds.

With the power cord plugged in and the batter reinstalled, I powered up, and the process of reinstalling the root hubs and their subsidiaries, which took quite a while since the last two driver searches took about 10 minutes. After that, I reinstalled each USB device, starting with a thumb drive, then the mouse receiver, then the cell phone interface (verifying the ability to get Windows Explorer to show the files), on each USB port in turn. After this, I was prompted to restart the computer, which I did with all USB ports empty again. After the second restart, everything works and the phone is charging.

One peculiarity of USB in Windows, which I'm sure most of you have noticed, is that a new device, once installed, is "installed" only on that particular port; when inserted into a different port, it goes through the driver install sequence again, until it "exists" as a potentially available "old" device on every port. I don't know if Windows 8, or 8.1, or 10 has corrected this. It is a minor nuisance with three ports, but with one or two hubs bringing the count to 8 or 10, unless the user wants to dedicate a port to each device, it can be tedious to install a new device COMPLETELY.

But the first tip did the job. I speculate that the problem may have started when the fourth port, described in the manual as the eSATA+USB sleep and charge, was used to connect a FitBit receiver dongle (in front of the mouse receiver), and then the phone, because there was no phone charging problem until then. I intend to avoid using that port at all until the computer can be replaced with a newer one.

Thanks for the help.

해당 답변은 도움이 되었습니까?

점수 3


Deep gratitude to Allen Richardson for his cure for my seemingly unsolvable USB problems with my Satellite C855-2FC. The fix restored all my ports including one which has been 'dead' for a couple of years.

의견 추가하세요

Here is how to fix USB Ports Not working In Windows 10

You can attach the USB device that is not being recognized, to any of the USB ports

Press WIN+R keys together to open the Run dialog box. Once it opens up, type in devmgmt.msc and hit enter key.

A separate window named Device Manager opens up. You need to find and expand the entry named Universal Serial Bus Controllers. Under the entry, find Unknown USB Device marked with a yellow warning sign.

Right click on it and click on the Uninstall option.

Finally, find the tab named Action at the top and choose Scan for hardware changes as shown in the screenshot given below. That’s it. Your USB device should work now.

Source:- http://merabheja.com/fix-usb-ports-not-g...

해당 답변은 도움이 되었습니까?

점수 2


What a giant pain this problem was! I didn't have non-working USB ports, but flickering, constant clicking of the mouse since the last MS Windows 10 update in May of 2018. I originally thought this was because my Logitech wireless mouse was bad. I bought a new one. That worked for a few days. Then the problem came back in full swing. (this may still yet be bad USB ports or some display issue.) However, it appears at least for how, when I checked for any new drivers, Windows decided I need to re-apply the last update. I did that and rebooted again. So far so good. I am using a second monitor as my main screen now, rather than my laptop display, but the mouse just going nuts affected the behavior on that screen before now, too. This laptop is about 4 years old and I suppose is at the end of its useful life, but how can I possibly know that?

Thanks this worked. It was easier using the link. One thing. There was no yellow triangle but a blue question mark that indicated the problem

의견 추가하세요

Try removing your Battery for 5 to 10 minutes. If you have a device plugged in you may have to reload its driver. ie. printer

해당 답변은 도움이 되었습니까?

점수 1


Had the same problem - just did this and it worked - thanks so much for the help. I have a Toshiba Satellite too - is this a common problem with this make? I have had quite a few problems with Toshiba - will not be buying one again!!

의견 추가하세요

removing the Battery and pressing holding the power button for 30seconds, will you connect the adopter to it before doing in or just after removing the battery then you hold down the button

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

I guys,

I'm facing intermitent issues with the usb ports at may toshiba satellite pro c650 with Windows 8.1 Pro x64. It happens when i pluged an usb stick and suddently all usb ports went down.

The laptop only has 2 usb ports: one where i connect the wireless mouse and another to connect usb sticks, disks and other usb stuffs.

I went to a repair shop and i was told that the laptop needs to replace the motherboard because the usb ports are integrated. That's a thing i'm considering...

I followed the steps described by Allan Richardson, by unistalling all usb roots at Device Manager. Then i closed the laptop and waited for a few minutes.

After that i pressed the power botton and waited for the complete boot, entered the session password and then pluged the usb mouse receiver. All went well. After a few minutes, the usb port stoped to work again.

I repeted the steps for a few times and all went as described before. The I stoped to uninstall the usb roots because every time i reboot the usb mouse receiver is recognised and work for a few minutes. But if i connect any other device in the other usb port, they stop to work immediatly.

Following other instructions, i don't remember where (probably here), i went to the properties of each usb roots and disabled all options at Power Management as the mouse worked for about one hour, then stoped agains (by the way, just when i writing this).

By disabling all options of the usb root properties could help someone!


해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

you can unplug from power after that it will work

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Toshiba Satellite L870D Part# PSKBQC-00R001. Windows 7/64 Home Edition.

I had performed a clean install, updated all Windows then hardware drivers starting with the BIOS (to 6.30) and found single left USB slot worked but 2 on the right didn't. Device Manager showed no driver but I could see it was getting power as the light appeared in USB Flash Drive when inserted. Yes I tried the above solutions, and then some, but avoided editing the registry. Turned out I didn't need to!

Solution: The BIOS update (to 6.30) automatically defaulted the USB to 3.0, so, only the slot on the left would work as it is 3.0 compatible. I downloaded the Toshiba HW Utility which allows you to edit the BIOS and selected the 2.0 USB button. Problem solved, all USB slots are working. Yes the BIOS 6.30 update on the Toshiba Canada site is specified for Windows 8 but I have it working in Windows 7/64 no problem .... well, accept for the 3.0 issue.

Bonus fix! You probably also had this problem ... Device Driver for SM Bus Controller not found.

Solution: AMD SMBus Driver http://support.lenovo.com/us/en/download...

And always remember .... there will always be beer :P Cheers.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

toddfer 가/이 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 17

7일 전: 137

30일 전: 661

전체 시간: 297,112