주요 콘텐츠로 건너뛰기

모델 A1297 Unibody: 2009 상반기, 2009 중반기, 2010 중반기, 2011 상반기 & 2011 하반기

543 질문 전체 보기

Thunderbolt Port not working correctly!

Here's whats going on, I have a Zoom TAC-2 Thunderbolt Audio interface which I've been using for sometime with another macbook pro 17" and it had no problems on a macbook air either..

Just today I tried the interface on two different 17-inch macbook pros of mine (one running High Sierra the other is El Capitan and it appears to get no power from either of them. At this stage I was thinking okay this has to be either the thunderbolt cable or the Interface has died on me somehow. First I hooked one computer to the other in target disk mode to test the cable, no trouble getting target disk to do it's thing, but I went ahead and bought a genuine apple cable anyway just to be sure, still no signs of life from the interface.

Finally in a "there is no way this is going to work but what the heck" moment I tried hooking it up to my brothers same 2011 model macbook pro 17 and voilà, it does its usual LED streak up light. This made me happy but it still leaves a lot of questions about my 2 macbook pros and their thunderbolt ports.

Is it possible they're not providing power through the correct pins? The pins look clean to me so I don't see any obvious issue and the fact it works for target disk mode also seems strange. Anyone have any ideas of what to try or similar experiences not getting power from their thunderbolt ports? Could this be software even?


Block Image

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 5
댓글 5개

Ola. Estou com o mesmo problema, e estou tentando a solução seguindo suas instruções.

Thank you. I have had the same problem and solved it thanks to your tip. More info in my comment under your solution. Is Thunderbolt firmware 22,1 and Port Micro-Firmware 2.1.3 the most recent version for this Mac?

@Wolfgang my problem now is that I can't install Yosemite to a USB to make it a bootable thumbdrive and save the day. I've had to learn about the Terminal and write some commands just to open a package (something like a zip file). So this is the Apple experience eh? If it weren't for the professional audio equipment I bought that's only compatible with Mac I wouldn't have touched this. They say and apple a day keeps the doctor away. Maybe the doctor knows something you don't ;)


Hi John Smith, so you are having problems in creating a bootable USB installer?

I can't really help you with Yosemite I think, but there are easy tools for this.

I had success with these two:



There was a problem with the actual Apple installer for Sierra. Maybe this solution I found can help you too:


@John Smith.

Hi, what is your system version? have you see this post : https://fr.ifixit.com/Réponses/Afficher/... ?

댓글 달기

답변 8개

선택된 답변

DAN! Okay I found out what the problem is, you're going to want to make a note of this as it will be helpful to others.

Firstly, I stumbled across this which provided clues https://discussions.apple.com/thread/787...

It's the firmware that is the issue! I noticed both the 17" models that wouldn't power on my interface had the same firmware as I posted in the screenshot! Firmware Version: d.0, Port Micro Firmware Version: 1.2.1

Unfortunately the correct firmware cannot be installed from any of the later versions of OS X (not sure from when, but presuming Yosemite?) so after a late night and a lot of mucking around I managed to get Mountain Lion 10.8.5 installed onto a spare toshiba drive I had, for some reason I couldn't install from an external caddy either so had to mount the drive internally. I also ran into an an error regarding installing from usb "There was a problem installing “Mac OS X”. Try Reinstalling". Considering how much time it took me I'm very relieved that my hunch was correct!

I downloaded this here: Thunderbolt Firmware Update v1.0

The newer updates 1.1 and 1.2 did not work at first saying "Your computer's Thunderbolt port does not need this update" and 1.2 says something about needing to be on 10.9, but I installed Thunderbolt Firmware Update v1.0 and then I was somehow able to install Thunderbolt Firmware Update v1.2 afterward.

Block Image

Now I just have to switch back to my SSD and go from there but at least I can see it's powering up now :)

Note to anyone reading this: Make sure you're plugged into AC power or the firmware update won't work (quite possibly why it didn't automatically update the first time around back in the day!). Also, take your time and breathe ;)

해당 답변은 도움이 되었습니까?

점수 5

댓글 4개:

Good discovery! Happy it all worked out.

Haven't encountered this problem so good to know.

Yes this was VERY helpful...oh my goodness YES. I was trying to help a friend with my diagnostic external SSD's (where I have ever system ever made w/like DiskWarrior and etc ...and it was killing me to be 10 1/2 slower over FireWire 800. This did the trick...now my good deed is NO longer being punished. ;-) :-p As I have one external that has all my diagnostics with ThunderBolt 2 and SSD. REALLY THANK YOU SO MUCH!!!

Thank you! I have had the same old d.0 Thunderbolt firmware and didn't know that it hadn't been updated automatically. This was really a nightmare because I couldn't use a Thunderbolt 2 dock (Akitio and CalDigit). Only the Belkin Thunderbolt 1 dock worked. I had to return the docks, because even Apple support wasn't able to point me to a solution.

Other than in your experience, on my MBP the Thunderbolt Firmware Update v1.0 was installed in MacOS 10.12 Sierra. But in order to be able to install the 1.2 update, I had to boot from a MacOS 10.9 Mavericks backup . In the end, I got the Thunderbolt firmware 22,1 and the Port-Micro Firmware 2.1.3 .

As it seems Apple has rolled out later Firmwares inside MacOS updates. No Thunderbolt update has ever reached my Mac, that's why I had to install it manually. So it might be possible, that there is even a more recent version.

Now I am curious to find out if anybody has a newer version installed on his or her Mac? And what do I probably have to do to get it?

This did not work on 10.7.5 or 10.8.5. Maybe it would work on 10.7.0 or 10.8.0 but no way to find it at this time. Follow force-install tutorial by Jean JD located lower, I added some notes in the comment or go straight to the source of the French forum: https://forum.macbidouille.com/index.php... (you can translate it via translate function in the browser), I added my comment there too. It should help You not to get stuck .

댓글 달기

Double check to make sure your ports are indeed Thunderbolt.

The older MacBook Pro's had mini DisplayPort which looks the same! The port needs to have a lightning bolt next to it. As an example, the 2009 & 2010 models have a DP port, both 2011 models have Thunderbolt.

해당 답변은 도움이 되었습니까?

점수 2

댓글 5개:

These are definitely both 2011 models and I can confirm both have the lightning bolt beside the port. Any other suggestions Dan? - Thanks

If that's the case your logic board will need repair or replacement.

The 17" models are highly sought so I would make the investment to get it fixed one way or another.

You may need to check your cables as its possible one is damaged which in turn damaged your system.

Also, make sure you watch your AC power! Peripheral devices need to be powered from the same common outlet and ideally via a surge suppressor or UPS. Lightning, as well as power surges, can damage things in very odd ways.

Thanks for the advice, is there a safe way to test the cable d'you know? It's possible the cable affected both machines I suppose! Noted on the power.. Did think the firmware looks odd though, it's saying "Port Micro Firmware Version: 1.2.1", shouldn't it be 2.0.7?

Don't have any tricks in testing the cables. Thunderbolt cables are tricky! Unlike a normal cable, the connector end of the cable has a buffering chip! Here's a good write-up on port: Thunderbolt 1,2 & 3. using a very fine probe (pushpin needle) you might be able to test the port power line or if you're bold cut a cable to gain access to the discrete wires and trace them out so you can make a test cable. The link offers the pinouts.

Sadly, I don't have my 17" with me (late 2011) so I can't tell you if mine is any different on the ports micro firmware. I'm not sure this is even changeable, as I think it's within the front-end port chip, not the controller. It wouldn't surprise me if the early and late models have different versions.

Both the machines I had the issue with are early 2011 2.2ghz models, although I'm not sure if that was the cause, could it have been that when the firmware was supposed to auto update that AC power was not provided causing these updates to be skipped? That's my best guess anyway, I haven't owned either of them since new so it seems possible previous updates were neglected and for whatever reason apple hadn't incorporated a compatible update into any newer OS X. Either way it's a huge problem but I don't know if apple would address it? I'll definitely be writing too ZOOM however, I'm sure apple would take them seriously about this..

댓글 달기

Hello Wolfgang.

Thirst thing : thank you very much.

I’ve install Sierra and the response of Firmware Thunderbolt 1.0 is the same :

“This update is not necessary for the Thunderbolt port of your computer”

I think it’s dead for my computer.

It’s too bad .

Have a good day.


REVISION from 01/01/2021

Hello everyone !

Here is a good news to start the new year.

Lately I worked on the case of creating a Mac OS installation key in Recovery mode with an El Capitan or Yosemite installer which comes with a dmg containing a pkg that we can find here for El Capitan.

I have been looking around for a while and found how from Recovery mode, with this dmg we can create an installation media without too much effort: D

And this is the method that allowed me to explore the firmware pkg and figure out how to force the system to take it into account.

Here is how I was able to successfully force the installation of Thunderbolt Firmware.

Be careful though: I was sure that this Firm was suitable for my MBP and that it was not going to break everything.

However it is highly risky if you do not really know what you are doing.

In short, I had the pkg from the dmg downloaded that I copy and extract in the directory Firm_Thunderbolt on the Desktop of the Mac :

pkgutil --expand ~/Desktop/ThunderboltFirmwareUpdate.pkg ~/Desktop/Firm_Thunderbolt

Which gives the following structure:

drwxr-xr-x@  7 jean  staff    224  1 jan 09:28 21.5-inchiMacThunderboltFirmwareUpdate.pkg

drwxr-xr-x@  7 jean  staff    224  1 jan 09:27 27-inchiMacThunderboltFirmwareUpdate.pkg

-rwxr-xr-x@  1 jean  staff  28896  4 avr  2012 Distribution

drwxr-xr-x  24 jean  staff    768 31 déc 07:38 Resources

drwxr-xr-x@  7 jean  staff    224 31 déc 07:39 ThunderboltFirmwareUpdate.pkg

The directory I'm interested in here is ThunderboltFirmwareUpdate.pkg.

 The others are either for the iMac or not used here. So I work in the  ThunderboltFirmwareUpdate.pkg directory

cd ~/Desktop/Firm_Thunderbolt/ThunderboltFirmwareUpdate.pkg

And here is its structure:

-rw-r--r--@ 1 jean  staff  87688  4 avr  2012 Bom

-rw-r--r--@ 1 jean  staff    500  4 avr  2012 PackageInfo

-rw-r--r--  1 jean  staff  84153  4 avr  2012 Payload

drwxr-xr-x  6 jean  staff    192 31 déc 07:38 Scripts

And here is the command that changes everything:

tar -xvf Payload

x .

x ./System

x ./System/Library

x ./System/Library/CoreServices

x ./System/Library/CoreServices/Firmware Updates

x ./System/Library/CoreServices/Firmware Updates/MacBookProTBUpdate10

x ./System/Library/CoreServices/Firmware Updates/MacBookProTBUpdate10/HPM-em-00020007.bin

x ./System/Library/CoreServices/Firmware Updates/MacBookProTBUpdate10/MBP-22-01.bin

x ./System/Library/CoreServices/Firmware Updates/MacBookProTBUpdate10/ThorUtil.efi

And now here is the new directory structure:

-rw-r--r--@ 1 jean  staff  87688  4 avr  2012 Bom

-rw-r--r--@ 1 jean  staff    500  4 avr  2012 PackageInfo

-rw-r--r--  1 jean  staff  84153  4 avr  2012 Payload

drwxr-xr-x  6 jean  staff    192 31 déc 07:38 Scripts

drwxr-xr-x  3 jean  staff     96  4 avr  2012 System

A System directory with the correct tree structure has been created by the tar command with the correct firmware. All you have to do is copy the MacBookProTBUpdate10 directory from ~/Desktop/Firm_Thunderbolt/ThunderboltFirmwareUpdate.pkg/System/Library/CoreServices/Firmware Updates into the native system structure of the Mac : /System/Library/CoreServices/Firmware Updates

There is however a little problem with Catalina, as the system is mounted in read only. Never mind. To go ahead you must first deactivate SIP from the Recovery mode terminal:

csrutil disable

Then restart and type the following command:

sudo mount -rw /

Then we copy the MacBookProTBUpdate10 directory which contains all necessary information for the installation of the Firmware on the System.

First we go to the install directory :

cd ~/Desktop/Firm_Thunderbolt/ThunderboltFirmwareUpdate.pkg


sudo cp -a System/Library/CoreServices/"Firmware Updates"/MacBookProTBUpdate10 /System/Library/CoreServices/”Firmware Updates”

Then you have to enter the command that allows the firmware to be updated.

The flashTBFirmware script which is in the Scripts / postinstall_actions directory gives us all we need. You have to open it with any editor (textedit for example) and here is its content:



my $targetVolume = $ARGV[2];

my $FirmwareDirectory = "/System/Library/CoreServices/Firmware Updates/MacBookProTBUpdate10/";

my $firmwareTool = "ThorUtil.efi";

  1. yes this is secure

my $debug = (-e "/tmp/com.apple.pkg.testing");


#set NVRAM for tbft (<rdar://problem/9282793> Use Safe Mode for T29 updates (EPROM, Micros) to prevent PCIe unplug during update)

system("/usr/sbin/nvram tbt-options=%04");

# bless the firmware

my $retVal = system("/usr/sbin/bless", "-mount", "/",

"-firmware", $FirmwareDirectory . "ThorUtil.efi",

"-payload", $FirmwareDirectory ."MBP-22-01.bin",

"-payload", $FirmwareDirectory ."HPM-em-00020007.bin",

"-options", "-o -ee -f efi-apple-payload0-data -em efi-apple-payload1-data");

debuglog("blessFirmware the result of the bless command is: $retVal");


  1. always exit 0

exit 0;


sub debuglog


  1. $_[0] is the argument to debuglog

system("logger -p install.info '$_[0]'") if ( $debug );


The part that is interesting us is here:

# bless the firmware

my $retVal = system("/usr/sbin/bless", "-mount", "/",

"-firmware", $FirmwareDirectory . "ThorUtil.efi",

"-payload", $FirmwareDirectory ."MBP-22-01.bin",

"-payload", $FirmwareDirectory ."HPM-em-00020007.bin",

"-options", "-o -ee -f efi-apple-payload0-data -em efi-apple-payload1-data");

This is the bless command which will start the Firmware installer during the next boot. You just have to adapt it to create the terminal command which match with your system and which can be found below:

sudo bless -mount / -firmware /System/Library/CoreServices/Firmware\ Updates/MacBookProTBUpdate10/ThorUtil.efi -payload /System/Library/CoreServices/Firmware\ Updates/MacBookProTBUpdate10/MBP-22-01.bin -payload /System/Library/CoreServices/Firmware\ Updates/MacBookProTBUpdate10/HPM-em-00020007.bin -options "-o -ee -f efi-apple-payload0-data -em efi-apple-payload1-data"

I admit that I was a bit anxious when I restarted the Mac, but I quickly saw the famous Firmware update bar progressing and then the Mac restarted and there I plugged in the Thunderbolt DDE which was recognised without any concern.

And now here's the Thunderbolt info:

Bus Thunderbolt :

  Vendor ID: : Apple Inc.

  Nom du périphérique : MacBook Pro

  UID : 0x0001000A156383E0

  Logical Unit: 0

  Version du programme interne : 22,1

  UUID du domaine : B6969003-5485-245E-8FED-2538703498FC

  Port :

  État : Aucun périphérique connecté

  État du lien : 0x101

  Vitesse : Jusqu’à 10 Gbit/s x2

  Réceptacle : 1

  Version du programme interne de Port Micro : 2.0.7

to compare with the old ones.

Bus Thunderbolt :

  Vendor ID:: Apple Inc.

  Nom du périphérique : MacBook Pro

  UID : 0x0001000A156383E0

  Logical Unit: 0

  Version du programme interne : d.0

  UUID du domaine : B6969003-5485-245E-8FED-2538703498FC

  Port :

  État : Aucun périphérique connecté

  État du lien : 0x101

  Vitesse : Jusqu’à 10 Gbit/s x2

  Réceptacle : 1

  Version du programme interne de Port Micro : 1.2.1

End of the adventure, thank you for staying all along this journey. : D

Many many thanks to my friend Dominique for the translation in English.

You can find the French version here : https://forum.macbidouille.com/index.php...


해당 답변은 도움이 되었습니까?

점수 2

댓글 5개:

Merci Jean! Ok this seems quite complicated but thank you for explaining it in such detail. I still have my 2011 MBPro and I'd LOVE to get thunderbolt working so I may try to follow your instructions. Merci encore. Rob

@leggy Hello.

No, it's not complicated. Just follow the explanation and if you have a problem you wave and if I can help you I will guide you.

Merci Jean, c'est très gentil de ta part. Wish me luck....... :)

Would like to add couple things to this tutorial that had me spent more time than it should have. I used the link from the French forum translated to English by the way. Follow all the prompts but make a note of the following:

1. ThunderboltFirmwareUpdate.dmg (Thunderbolt Firmware Update V1.0) can be downloaded from the Apple website right here: https://support.apple.com/kb/dl1407?loca....

After this process is done - You can download and install V1.2 regular way

2. Scripts folder is located inside the ThunderboltFirmwareUpdate.pkg

3. No need to open flashTBFirmware file and make any modifications to it. All that needs to be done at the end after you copy MacBookProTBUpdate10 folder to the Core Services/ Firmware Updates folder is to open Terminal, type sudo following by the space, drag flashTBFirmware file inside the terminal window and press enter. That's all. After that You restart the computer and firmware update will take place after reboot.

Thanks Elektrosha for this. I still have my 2011 MB Pro with non working thunderbolt so I'll go back and try again using your advice. Will let you know how it goes!

댓글 달기

First of all thank you for finding out a way to fix the thunderbolt problem on the 2011 MB Pro. I’d like to install the newer firmware on my 2011 machine too. Because I have a recent OS running (Catalina) I need to boot from a Mountain Lion image which I have on a USB key. I can boot from it but does anybody know how I can then run the firmware update file? Do I need to go into terminal to do it because the only options I have when I boot from USB are restore time machine backup, install Mountain Lion or disk utility but there seems to be no way to browse to the firmware update file to install it. Thanks in advance. Rob

해당 답변은 도움이 되었습니까?

점수 1

댓글 3개:

Hi leggy, if your MB pro runs Catalina then it is most likely not a 2011 model. The latest Mac OS that the 2011 MBPs can run is High Sierra. So, better check out your model by clicking on the menu bar Apple logo and choosing “About this Mac…. ” and then search the appropriate firmware installer for you machine.

I haven’t used a bootable USB installer Stick for my updates. I have installed the OS on a USB drive and booted from that.

Regarding the firmware version, you (and other’s who are coming here by search engines) should be aware that every Mac generation has their own firmware versions (and version numbers), probably because the hardware is a little different.

So, regarding the early Macbook Pro 2011, 17” model and probably also the 15” model, I am quite sure by now, that Thunderbolt firmware 22,1 and the Port-Micro Firmware 2.1.3 are the most recent versions.

And in addition to that, I happily found out that the updated Thunderbolt can now run a Thunderbolt 2 dock, which it couldn’t before.

Hi Wolfgang. Thanks for your reply but mine is a 13" 2011 MB Pro and they can actually run Catalina. If you do a search there's a very simple method and it actually works very well. So in fact you're saying that rather than booting from a USB key I should install OS X Mountain Lion on an external drive and then boot from that to install the Thunderbolt firmware update as the original poster did above to fix his problem on a similar machine to mine? That's the problem I'm having just being able to run the installation file. I'll give that a go. Thanks.

Yes, that was the procedure that worked for me. But I had to go all the way from first the 1.0 update then to the 1.2 update.

Off topic: I would avoid Catalina, as long as I could. But the install process means a lot of disadvantages for my computer (even with Mojave), so I didn't even try it out of curiosity.

Good luck!

댓글 달기

I still can’t install the firmware update (getting that software is not supported by this system). I’m suspecting it’s because my firmware version is up to date (27.1), but not the Port micro Firmware version 0.15.0. I’m suspecting it’s that latter one causing the problem of not detecting the device.

Do you have any other clue how to update that micro firmware?

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

It turns out my newer laptop, despite having an identical model# to my older laptop, has a slightly different quirk. The “newer” one’s DVI port does not double as a Thunderbolt like my older one. No amount of firmware updates will enable this function. I blew a bunch of money for the wrong device completely.

해당 답변은 도움이 되었습니까?

점수 0

댓글 1개:

The DVI port is only a video port. It can't support a Thunderbolt display it can support a mini DV adapter to connect a mDV display.

댓글 달기


I have a MBP Early 2011 and the Thunderbolt version are there :

Bus Thunderbolt :

  Nom du fournisseur : Apple Inc.

  Nom du périphérique : MacBook Pro

  UID : 0x0001000A156383E0

  Chaîne de routage : 0

  Version du programme interne : d.0

  UUID du domaine : B6969003-5485-245E-8FED-2538703498FC

  Port :

  État : Aucun périphérique connecté

  État du lien : 0x101

  Vitesse : Jusqu’à 10 Gbit/s x2

  Réceptacle : 1

  Version du programme interne de Port Micro : 1.2.1

My os version is 10.13.6 and the update firmware 1.0 :


don’t work. I have try with Mountain Lion, Maverick, Yosemite and the response is alway :

“Cette mise à jour n'est pas nécessaire pour le port Thunderbolt de votre ordinateur.”

“This update is not necessary for the Thunderbolt port of your computer”

Il don’t know if there is a way to force this update?

I will try later with a clone of Snow Leopard 10.6.8.

If somebody as an genial idea, thank you in advance.


Update (10/21/2020)

I have try with Snow Leopard, same response : “This update is not necessary for the Thunderbolt port of your computer”

i'm desperate. :-(

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:


Nobody can help me?

Hi Jean JD, I have read my own post here again (it has been a while), as well as your information. I can only guess where the problem could be.

In contrast to you, I have done the 1.0 update in Mac OS 10.12 and I did the Thunderbolt 1.2 update in Mac OS 10.9.

With some older Apple installers I have experienced that the signing has expired over the years. And error messages can sometimes be misleading.

So it may be worth trying the 1.0 update with Sierra and if this doesn’t work, with the date set back to or before September 2019 (and make sure your computer is offline).

Sierra can still be found here:


(And if you want to create a bootable Sierra USB-stick, I have managed to do that with the “Sierra Patch Tool” by “dosdude1”, but that is a different story.)

Good luck!

댓글 달기

Hi, I've got the same problem with my MBA Early 2015. My firmware was updated but the thunderbolt controller firmware was not. Tried everything but my skills are not up to this task. Can you help-me somehow? Maybe with a tutorial for MBA? I think a lot of users have this problem, and Apple does not care. Thank you so much.

My Thunderbolt config:

Barramento Thunderbolt:

Nome do Fabricante: Apple Inc.

Nome do Dispositivo: MacBook Air

UID: 0x000100180A528C40

String de Rota: 0

Versão de Firmware: 27.2

UUID de Domínio: B117FEDF-264B-0D5C-94ED-E3BBDEC0C844


Estado: Não há nenhum dispositivo conectado

Estado do Link: 0x101

Velocidade: Até 20 Gb/s x1

Largura do Link Atual: 0x1

Receptáculo: 1

Versão do Firmware do Controlador de Link: 0.15.0

해당 답변은 도움이 되었습니까?

점수 0

댓글 4개:


Hi, What’s the real problem with your Thunderbolt port? Disk or Video?

Video is not working...

Hi Leonardo,

When the MacBooks firmware is updated, that doesn’t mean that automatically the Thunderbolt firmware will also be updated. So maybe the firmware you have is the latest version available for your computer.

Unfortunately, there is no official list that shows which firmware is the latest for each Mac. To add to it each Mac model has different Thunderbolt firmware numbers. This thread here originally started with a different Mac than your’s, so be careful when you compare the numbers.

What makes you believe your Mac’s Thunderbolt firmware should have a newer version number? What exactly is not working correctly?

Hi guys, thank you for your reply. I know that it is a diferent model. I've got no video on thunderbolt port. Cable is working and the monitor too, tested in other Macs. I tried everything, installed All macOS versions from El Capitain to Big Sur to see if it works. What I found different is that when I connect the cable, the system freezes 4 times for about 3 seconds, like it is trying to connect, and then nothing happens.

댓글 달기

귀하의 답변을 추가하세요

Shannon 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 8

7일 전: 45

30일 전: 191

전체 시간: 73,422