주요 콘텐츠로 건너뛰기

Repair guides and support for the EOS 70D, a DSLR camera released by Canon in 2013. This camera can be identified by the model number DS126411.

66 질문 전체 보기

When I take a picture my picture is a white screen

Hi,

When I take a photo on my 70d canon camera, it’s just a white screen. It’s not the display as I can look at old photos on camera. I have tried a different lens. I have re formatted the SD card. I have tried without flash. Does anyone have an suggestions before I send away?

thanks!

Update (10/02/2018)

Block Image

this is the image I see (regardless if SD is in or not)

Update (10/02/2018)

Block Image

it is no longer there. Just a normal menu screen. I thought I had left the battery out, though I will try that for two days this time!

@jayeff

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
댓글 5개

Hi @emilysmith , have you fixed your problem? If so then how much does it cost? I also have the same problem

Hello, please have you fixed the problem? I have the same issue.

I am about to tear down a 70D with this "Image Snow" issue and will report back with some more detail once I'm in and diagnosed the problem.

Everything I take a picture it is just a white screen

I am also facing the same problem videos and picture are white. Showing Err70

댓글 달기

답변 1개

선택된 해법

Hi @emilysmith ,

Try taking a picture (I realize that you cannot “see” what you are taking) and then download it to a computer.

If the picture on the computer is OK then most likely you have a motherboard problem in the camera that is not allowing the image being “seen” by the camera’s CMOS image sensor to be transferred to the camera’s display screen, which you say is still working. (can you view the menu screens OK?)

If the picture on the computer is not OK (perhaps just a black image) then most likely you have a CMOS image sensor problem or a motherboard problem or both.

Replacement CMOS image sensors are not cheap. (Although if this is the problem you may find one cheaper ;-)

Update (10/02/2018)

Hi @emilysmith ,

Having now seen, after your update, that the “white screen” you mentioned is actually an error message perhaps the card slot is the problem by not detecting the presence of a card (have you tried a different one?) and not what I suggested above

If it is not detecting the memory card, perhaps that is why you cannot see an image. No point showing you a new image if you cannot "save" it to anywhere.

This is just a guess on my part and may be totally wrong

해당 답변은 도움이 되었습니까?

점수 2

댓글 2개:

So when I upload to the computer the image is the same as what I see on the lcd screen. I can access the menu and everything else is ok apart from the lack of visible image.

Thanks for your help @jayeff

Hi @emilysmith ,

So when you access the menu screens the "no card in camera" message is no longer there or is it just overlaid by the menus?

Also have you tried removing the main battery and leaving it out for a day or so (this allows the camera's non removable date and time battery to discharge) so that hopefully the camera will revert back to its' factory default condition and if any settings were corrupted for any reason and they were the cause of the problem they will be released. Worth a try.

The camera's internal battery is kept charged by the camera's removable main battery and maintains the settings when you have to change the main battery, so it will be charged again when you insert the main battery

댓글 달기

귀하의 답변을 추가하세요

Emily 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 1

7일 전: 13

30일 전: 68

전체 시간: 8,198