주요 콘텐츠로 건너뛰기

Apple 주문 번호 MC007LL/A / 27" 2560x1440 픽셀 화면

78 질문 전체 보기

Faint pixel thick vertical lines on Apple Cinema Display 27"

I bought old used a1316 Apple Cinema 27” Display to connect to my 15” MacBookPro (Early 2013) and just use both at home mostly for browsing and movies.

Today I noticed faint pixel thick lines about inch from each other all over the screen. Clearly visible on dark backgrounds when MacOS is in DarkMode, but almost impossible to see if screen is completely black or white.

Screen on macbook is fine. I played with different resolutions, reset PRAM, rebooted machine, tried different thunderbolt connectors…

So far, if I’m far enough from the screen it’s not bothering me much. But just wanted to know is this is something I need to worry about? Can the condition of the screen deteriorate?

I made a photo of the screen, not sure how visible issue will be:

Block Image

Thanks in advance!

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
댓글 2개

Got exactly the same problem on my iMac27 late 2009 (which uses a LG LCD). Would be interested to know what specific parts (capacitors?) need to be replaced... Obviously I don't wanna start replacing all possible caps before finding the right ones..

Could you please tell me, were you able to solve this issue? I'm currently facing a similar situation and am considering whether it's worth trying to fix it or if it's better to sell the device.

댓글 달기

답변 2개

선택된 답변

Your display uses LVDS signaling so it can encounter noise issues either within the LVDS cable or its connections internally. Another source of noise is aging noise clapping capacitors on the logic board.

At this point if you can live it I would. If it really is bothering you, you could try fixing it but the likelihood of solving it without major parts replacements is not likely.

해당 답변은 도움이 되었습니까?

점수 4
댓글 달기

Hi i have similar problem bars and white lines, opened up monitor to check noticed this?

Block Image

, see chip with red marking looks

Block Image

해당 답변은 도움이 되었습니까?

점수 0

댓글 4개:

Hello, I also have such a problem and want to try to fix it. After correcting it, I plan to describe the result. I found your message and would like to check it, but there is a problem, which is that this chip is an EEPROM (Electrically Erasable Programmable Read-Only Memory), which means that the firmware needs to be written to the new chip. Could you please describe in detail how you solved this problem, or perhaps you already have another solution?

@imortl - Sorry, this is not the issue. As you noted this is an EEPROM chip. The issue you are facing if its the same lines repeating is a timing issue where noise is sneaking into the LVDS signal lines. This kind of issue is always old electrolytic capacitors which have broken down.

@danj thank you very much for the explanation, any help for me is the last hope for repair. please tell me, do you know which group of capacitors on the circuit should be replaced? can I leave you my e-mail and I will send you a picture of the circuit? imortldrumandbass@gmail.com

@imortl - Sorry I can’t pullout the ace of spades from the pack of cards without looking😏 But, you should be able to! Of course looking in your case.


The trick is first physically looking at the caps both Electrolytic and Tantalum Capacitors looking for damage. Then measuring the power rails and grounds referencing the schematics and board views.


Once you’ve identified the cap you’ll need to replace it, do you have the needed tools and have the skills? If not you’ll need to seek out someone locally, hopefully with iMac repair skills.

댓글 달기

귀하의 답변을 추가하세요

Andy 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 1

7일 전: 5

30일 전: 76

전체 시간: 1,677