주요 콘텐츠로 건너뛰기

Philips Alarm Clock radio for iPod/iPhone AJ6200DB/98.

1 질문 전체 보기

Why is Philips Clock Radio showing - - : - -

My Philips Clock Radio AJ6200D/98 was working fine. I unplugged it and when I plug it back in, it is now showing - - : - - for the time. None of the buttons are responsive. I’ve turned it off and on, hold the source for 3 seconds, read the manual but nothing. Any ideas?

Block Image

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기

답변 1개

선택된 답변

Hi @munchine ,

Has the clock/radio got backup batteries installed at all?

Here’s a link that shows where they’re located.

If so, disconnect the power from the device then remove the batteries.

After they’ve been removed, turn on the device for about 10 seconds and then turn it off again. This is just to dissipate any residual charge left in the device that may be holding any corrupted settings that may be preventing a normal operation.

Then reconnect the power to the device and see if it is now working etc. You can leave the batteries out at this stage as they are only there to maintain the settings in the event of a power failure. Also check if they may need replacing by measuring their voltage with a digital multimeter (if you have one) or if you think that they’ve been there for a long time.

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:

I didn't have the battery in but after reading your comments, I left it disconnected over night and it worked the following morning. Thanks.

@munchine

Thanks for the feedback.

Maybe I was too optimistic about it only taking 10 seconds to dissipate and reset and should have specified a bit longer, perhaps 5 minutes turned on without power.

Regardless you solved it in the end.

Cheers

댓글 달기

귀하의 답변을 추가하세요

Mach 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 1

7일 전: 3

30일 전: 28

전체 시간: 790