주요 콘텐츠로 건너뛰기

The official wheel for the Grand Turismo game on the Playstation 3. The Logitech Driving Force GT E-X5C19 features an advanced haptic feedback system to make racing even more realistic.

2 질문 전체 보기

Force feedback just stopped working

So, I have a Logitech DFGT wheel that has been working without any problems for a few years now. Today, randomly FFB just stopped working, I tried reconnecting it and etc., but zero response. The power brick works, we tested it. Wheel gets detected by the computer, testing shows that all the buttons work, port for power also works. Tried reinstalling the software, didn’t help. The only problem is FFB. Any ideas where should I start looking?

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

Few items come to mind (and I don't own this perpheral)...

1. either the force/haptic feedback engine/motor has died (almost unlikely).

2. the board component powering the engine has died (possible).

3. there is a disconnection between the board and the engine (i.e. the gears have lost teeth and just spin without contact).

You might want to check to see if there is any physical damage internally first.

@dunc I did take it apart and there's no obvious damage. All the wires, connectors, board itself look fine. It wasn't dropped or anything, it just stopped working while playing. The wheel doesn't even try to calibrate, which it did before and the LED in the middle just turns on for a second when I connect it to the computer and turns off. I guess it's something with the board, for which I don't have any experience to try and fix, maybe I'll try to look for someone who knows more than me and maybe they'll be able to do something.

@Tomasz Videos Yeah, that's more detail than I knew. It's very possible that the board needs replacement. I think you'll be hard pressed to find parts of this peripheral due to the "break then buy" effect as well as just the limited amount of units sold.

I found one on eBay and you may want to purchase and keep your broken one for parts. I'll post the eBay auction number, just do a search and you'll find it (I'm assuming you are in the US).

eBay auction 224357013793 - Feb 19, 2021

@Tomasz Videos One other thing that just came to mind after seeing this guide:

Logitech driving force gt ''play''or ''loose'' steering fix

See if you can reach out to the author in that guide to see if he has any insight. Since this is a single board device, I recommend not making any changes to it because you may damage it further. Keep in mind, the board can flex from the pushing and pulling on the outer case and since they are multilayered bords, a trace can get damaged (possibly). Check to make sure the motor moves by disconnecting it and putting a quick connection to a 9v battery.

Lastly, provide that board number or a photo of it so that maybe someone in these forums can provide you more replacement info.

@dunc Sadly, I'm not from US. Even if I was, I'm definitely not buying another wheel at the moment, because if everything goes as planned, I'm going to get my drivers license and that is quite costly here. Even if I could buy another wheel, most likely I would upgrade to an at least Logitech G27. I did try to test the motor, that works, tried cleaning the sensors on the optical enconder, that didn't help either. I'll try to reach the author of that guide, but our problems are quite different.

7에 댓글 더 나타내기

댓글 달기

답변 3개

선택된 해법

So, I sold the wheel, quite a few months ago now actually, but only now I remembered to do an update, because maybe, it’ll be useful for someone. The guy I sold it to, found the problem and it was something with the sensor which counts how many times wheel rotates, I’m guessing that’s going to be the optical enconder? It’s a translation, so it might not be accurate, but he said that the problem was that a few traces were broken on the sensor’s board and one of the connectors was moving a bit.

TL:DR; If you have a problem similar to mine and a new power adapter doesn’t help, chances are the problem lies in the optical enconder.

해당 답변은 도움이 되었습니까?

점수 1

1 Comment:

Thanks for coming back to update. It is appreciated and I promise you, it will help someone in the future.

댓글 달기
가장 유용한 답변

Do you have the ability to measure the voltage while the steering wheel should be powering up? Measuring the power supply voltage unfortunately doesn't really tell you much, because if there is no current being drawn while the thing is actually defective, it can suggest perfect operation, whereas, when the steering wheel should be powering up and you see the voltage drop significantly, you might be a little wiser.

1. Measure the terminals at the board upon power up or

2. Take a ceramic resistor to act as a device that's causing a current draw (one of those big white square resistors).

Next step if previous is ok: measure the current drawn between the supply and the device requesting this current.

Take the maximum output as a threshold, anything well below that (and I'm talking milli-amps above or even a full zero here) and you might be looking at a power supply that seems to behave right, but actually isn't.

If that's true, try to look inside the powersupply and see if there are worn out capacitors

해당 답변은 도움이 되었습니까?

점수 1


My grandpa did a test with a lamp and the power supply and the lamp did light up with it. He had a random light with wires and just somehow connected it to the power supply. Don't know if that changes anything, but I'm just throwing it in there just in case. I'll try what you suggested or maybe I'll just try to get a different power supply.

If that was a 24V bulb it can be a good test, except for the fact that it tells you it can deliver current, not at what voltage and the amount (perceiving brightness can be a difficult thing).

Also, if the starting current requested by the lamp was sufficient enough for the sensing circuit of the power supply to steer open immediately instead of maybe having a controller check for the right voltages first and upon seeing everything is OK then kick everything after that controlling function into action, it could unfortunately also prove nothing.

The thing is that a light will not show high frequency noise on the power supply line that might cause the controller to freeze (logic chips really need stable voltages in order for them to operate normally.

Only a scope can do this and unfurtonately if you don't know someone who has one, they are not exactly cheap to just go out and buy.

You might get lucky having a multimeter on the AC setting measuring voltage. If the reading jumps a lot, that's a sign of noise.

댓글 달기

So, an update after a month. I ordered a new power adapter from Aliexpress, instead of doing some more testing. It finally arrived and the wheel is still dead. Checked the voltage on the adapter with a multimeter, that's seems fine. Chances that it has the same problem as the previous one I guess are small, so most likely it's something in the inside of the wheel, which is really sad. Thanks for trying to help and I at least learned a few things.

해당 답변은 도움이 되었습니까?

점수 0

1 Comment:

Sorry to read mate. Glad you didn't give up until the very end.

댓글 달기

귀하의 답변을 추가하세요

Tomasz Videos 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 1

7일 전: 27

30일 전: 141

전체 시간: 2,189