MSI GS60 refuses to turn on

Hey everyone,

A couple of days ago after restarting my machine it refused to turn on. Taking out the battery, draining the remaining charge and inserting the battery back did not help, neither did resetting the cmos battery. As a last ditch effort I unscrewed everything again and took out both RAM sticks + SSD and then put them back in. This did the trick, but unfortunately for only a couple of days.

This time, I was browsing the web and stepped away for a moment. Once I came back, the machine had turned itself off. I again tried resetting both batteries and taking out RAM + SSD, but this did not help anymore. I also read online that you have to wait about 15 minutes before inserting the battery back in, sadly this did not help either.

Before this incident the machine had served me well for around 4-5 years. I had to replace the HDD and battery once, but apart from that no issues at all.

I tried turning the laptop on without the battery installed and just plugged to the wall, and it did this: ++https://vimeo.com/612632058++ (sleep mode LED with the moon icon was also beeping). This icon also beeps each time I insert the battery back into the laptop after draining the charge, but after that nothing happens with it installed (as shown in the video only happens when there is no battery in the laptop and I connect it to the charger).

Has anyone encountered something similar with this model? Are some other parts in need of replacing? Would greatly appreciate any and all suggestions.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
댓글 달기