주요 콘텐츠로 건너뛰기

The Philips Satinelle Essential is a corded epilator designed to gently remove hairs as short as 0.5mm from the root. Model Number: HP6401/50

3 질문 전체 보기

Can I get some help with my Philips Santinelle Ice?

Block Image

Block Image

Block Image

Block Image

Block Image

I have an old Satinelle Ice, which isn't cordless. I believe the wire connection is what is going bad because it works when I use the device in certain angles. Have you come across this model in particular? Just wondering how to fix it. Actually I can't even open it. The screws shown on the transformer are not the typical type, the head has to small indentations but not + cross or the __ continues line. It's more like this - - . The one on the actual device isn't a screw, I know it looks obvious but that is sort of like a "sliding metal door" (best way I can describe) You would think there is a screw behind but none that I can see.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 6개

Hi @bellanarva64522,

Is there a model number printed somewhere on the device?

Hum....Not something clearly stated "Serial Number" but there are some numbers in here. N 4120-1240-DC and there is another set "Listed 49j6 e82272" This information is on the Transformer.

I just tried uploading some pictures. I really don't think they were made to be open.

Hi Bella,

Here's a guide showing you how to add pictures to your question.

기존 질문에 이미지 추가하기

댓글 1개 더보기

댓글 달기

답변 2개

가장 유용한 답변

Okay, let's start out with the easy part; the one I can actually answer right now. The screws on the AC adapter, or transformer as you called it, are security screws, meant to make it harder to take it apart. They require what's called a U-shaped security driver. The bit for that screwdriver looks like this.

Block Image

If it turns out to be necessary to open the AC adapter, that's what you'd need to get, but at this point I don't think it'll be needed.

So your epilator runs on a 12VDC power plug and that seems to be giving you problems. It's not at all uncommon for a cord like that, one that has to be plugged in while in use, to eventually fray and stop working correctly. So I think our next step is to try and figure out whether it's the cord or the epilator plug that is having the problem; either one is a distinct possibility.

I'd probably start by looking at the cord. Unplug it from the epilator (I assume it unplugs, doesn't it?) and look carefully at the wires where they come out of the jack. That's the point at which they get bent the most, and therefore the first place the wires will fail if they're going to.

If you have a voltmeter that would be ideal. You can put the positive lead inside the barrel and hold or clip the negative lead to the outside of the barrel. Plug the AC adapter in and verify you're getting 12 volts. Now, while you're holding the voltmeter contacts steady on the plug, wiggle the wire back and forth, up and down, and around and around. If you see the volts cutting out as you do that, then you've most likely found the source of the problem.

If it looks like the plug has gone bad, you'll need to replace it. You've got a couple of options here; you can either just buy a whole new AC adapter and call it good, or if you can determine the size of the plug you need, you can simply buy a replacement plug and wire it in yourself. Note that it will probably require soldering to do so, although not always depending on what kind of replacement plug you get; some of them can be connected by crimping.

If you can't find anything wrong with the plug, then we'll have to look at the jack inside the epilator. So take a good look at the plug and let us know what you find.

해당 답변은 도움이 되었습니까?

점수 1

댓글 3개:

Jerry,

Thank you so much. I didn’t even know this U-Shape security driver existed. Already learned something today. I truly believe the issue is in the cord but unfortunately the cable is connected to the epilator, it’s not a plug in. And, I think it is the part that is connected to the epilator and not the AC adaptar (learned something else ;) that has a connection problem. This assumption is base on the fact that the epilator works when I use on a certain angle. So I really need to open the epilator. Would it be helpful if I took a

Closeup picture of that “funky” part of the epilator? The one I can’t find works to describe?

@bellanarva64522 Sure, more pictures couldn't hurt. Also a pic or two of where the cord goes into the body of the epilator might give us a clue.

I'll keep looking online for any information on how to get it open in the meantime.

Jerry,

You are right. I completely forgot about this ice cooling attachment, that’s why it’s called the Satin Ice. Ok so we’ve eliminated that possibility too. I’m adding the new pics to the initial post. Thanks again.

댓글 달기

Hi Bella,

I think I've got a clue about that hole on the bottom side of the epilator. I believe its a mounting point for an accessory called a skin cooler; you freeze it then attach it to the epilator to help alleviate the pain of doing large areas like your legs. Here's an excerpt from the user manual.

Handleiding Philips hp 6433 satin ice (pagina 1 van 100) (Nederlands, Duits, Engels, Frans, Deens, Zweeds, Noors, Fins)

Block Image

So I don't think that part has anything to do with opening it up; I'm guessing there's a couple of springs in there that grab onto the end of a post sticking out of the skin cooler to hold onto it.

(UPDATE 4/16/23)

Okay, so there's no sign of any fasteners that can be accessed any place we can see. That leaves a couple of possibilities; the most common ways I've seen a device like this being fastened together are either clips or glue. Naturally it's a royal pain in the a** if they've simply glued it together; that means they've left no provision for it being opened up again for repair.

So let's go with the first option, that it's clipped together somehow. I haven't found anything at all on your specific model and how to open it up, but on other models none of them have been glued, so that's a good sign.

First thing to try is the method I saw on another model where a part you exposed by taking off the head comes out. On one of the guides on the device heading your question is filed under it shows how to disassemble the epilator by prying out the mechanism that drives the gears on the head.

Philips Satinelle Motor Replacement - iFixit Repair Guide

Step 2 shows the process; I believe it's different for your epilator, but it may be that the concept is the same, that you need unclip something here in order to get the two halves to come apart. On yours I'm thinking you might try a flat blade screwdriver inserted in one or the other of the two openings I've marked.

Block Image

Try prying in there, but don't be too forceful about it; I don't want you to break something that will render the epilator useless. Check around the edges and see if there's any kind of clip or retainer holding that mechanism in.

Also, I'd like to ask for one more photo; take one of the side of the epilator so we can see how the seam separating the two halves meets up with the top of the device where the head fastens on.

I know this is taking a while, but we're groping in the dark here so it's going to be an exploration to figure this thing out.

해당 답변은 도움이 되었습니까?

점수 1

댓글 2개:

I will try this over the weekend. It might be something simple for some people but it is like a half day project for me. I will take pictures of the inside of the machine once opened. Remaining optimistic

Hi Jerry,

I opened the little flat and tried to pry the halves open but i was afraid of breaking it. So I decided to take a picture and share with you. Any suggestions?

댓글 달기

귀하의 답변을 추가하세요

Bella Narvaez (SimplyBella) 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 1

30일 전: 22

전체 시간: 218