주요 콘텐츠로 건너뛰기

The fifth-generation Elantra debuted at the 2010 Busan International Motor Show in April 2010. The fifth-generation Elantra (2010-2015) added a two-door coupe variant in addition to the standard four-door sedan model. These Elantra vehicles included six-speed automatic or manual transmissions.

25 질문 전체 보기

Where is my output shaft sensor?

Where is my output shaft sensor located and why would the circuit have no signal?

Update (04/19/23)

Thank you So first my first gear went in limp mode I couldn’t go and drive so I would switch it over to second gear then it started hesitating so I parked it I change the input output sensor it drove for about 30 miles it was finevand then the same codes popped off ever since then it won’t go in drive or second but everyone I take it to tells me it’s the whole entire transmission which I don’t think so because there’s a lot of sense or problems that could mimic the same problem as an internal transmission problem but it’s not I think it would be smart to eliminate the small things first before I go to the big things the expensive things. Code P0722 and firts gear incorrect ratio code And a guy mess with my tires right before all this happened also before that my car is a 2016 it was running just fine

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
댓글 1개

@erinevans26907 sounds like you got some feedback from having your Hyundai scanned :-) What are the issues with it and what makes you say that the "circuit have no signal?" Any scan code?

댓글 달기

답변 2개

가장 유용한 답변

Hi Erin,

The output shaft sensor on your car is what is known as a Hall Effect sensor in that it uses a magnetic field to detect a reference point on a rotating object. In this case it's being used to measure how fast the output shaft of the transmission - the part that goes to the wheels to turn them - is turning. There's a companion input shaft sensor that measures how fast the engine is turning and the difference between the two lets the transmission computer know how efficient the transmission is operating and what speed and gear its running at.

In your car the input and output shaft sensors are mounted near one another underneath the valve body of the transmission. That means it's not an easy job to replace; you have to drain the transmission fluid, remove the transmission pan, and disassemble the valve body in order to get to it. It's doable, but does require what I'd call medium to advanced home mechanic skills. It's something I would personally tackle, but then again I've been wrenching on my own cars for a good 50 years.

Those sensors can fail for any number of reasons. It could be a problem with the wiring, the sensor itself or the transmission computer's circuitry that reads the sensor. Most of the wiring harness that typically fails on that part is once again inside the transmission so even checking that requires the same disassembly I mentioned earlier.

Here's a video that shows the procedure for replacing the sensors; they finally get to where you can see them at about 10:45 into the video.

HYUNDAI INPUT OUTPUT SPEED SENSOR LOCATION REPLACEMENT SONATA ELANTRA SANTA FE TUCSON VELOSTER ACCEN - YouTube

There's a discussion of this over on the Hyundai forums that also includes a video.

2016 hyundai elentra output speed sensor - Hyundai Forums

One user has an additional comment that might be of interest.

If you going to tear the thing apart, I would suggest you replace the internal harness also, especially if the plug on top of the transmission case is black. the new part has a brown connector. the black harness was had concerns with solder joints at the main connector, and new part has temp sensor integral to harness, not 2 piece.
Refill with proper Hyundai ATF, usually a bit over 5 bottle is needed to do it

So something else to consider if you decide to tackle this yourself.

Good luck with your repair; let us know what you decide to do and how it turns out!

해당 답변은 도움이 되었습니까?

점수 2

댓글 1개:

@erinevans26907, So you've replaced the sensors themselves, or at least the output sensor and are still getting the problem, I take it?

Given the comment on the Hyundai forum about the wiring harness, I think that's the next thing I'd be likely to try.

댓글 달기

@erinevans26907 sounds like you have a good plan. Besides the great answer provided by my colleague @dadibrokeit this may help you out a bit as well. This is not a separate answer, just an augmentation to the prior given answer.

Here is the replacement procedure for your output speed sensor:

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Besides your wiring harness etc., you also want to go ahead and reset your TCM and check that as well. You can get all the information about all of that by using the service manual. You have free access (who knows for how long ;-) on here

해당 답변은 도움이 되었습니까?

점수 1

댓글 2개:

Thank you so much 😊

I am having issues with a 2015 elantra not going into drive. Mechanic replaced the harness and the input/output sensors and the car ran fine until we turned it off and turned it back on. The it wouldn't move when in Drive again. The scanner says the output speed sensor isnt getting a signal but it's brand new. Any idea what to try next?

댓글 달기

귀하의 답변을 추가하세요

erin evans 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 4

7일 전: 31

30일 전: 153

전체 시간: 1,484