Apex pro TKL not working

can someone please help I have a Apex pro TKL it lights up but doesn’t work or type. Nothing works on it.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글 12개:

Hi @noxfnl

Have you tried using a different, known working, compatible USB cable between the computer and the keyboard and checked if that worked, you didn't say?

@jayeff I tried everything factory, resetting my PC reinstalling drivers taking all my key cap off my keyboard cleaning it everything works. It just does not type at all and LED are all not the same I just got this keyboard please help!!!!!!!!!


You never mentioned using a different USB cable, rather than the one supplied with it (if there was).

If possible try connecting to another computer.

If still no good, since you just got it, take it back and get a replacement.


Was the keyboard working before?

If not, just verifying that you connected the USB cable to the correct USB port on the keyboard?

One is for the keyboard and the other is just a "pass-through" allowing you to connect other USB devices to the PC

Here's how to post images in your question

기존 질문에 이미지 추가하기

Yes, it was working before and it automatically changed a couple keys to a different color and it locked up and I couldn’t do anything. I just need to unlock it. It’s so hard. I tried a different USB cable and try to plug it in to a different PC and same thing happened $300 down the drain

댓글 7개 더보기

댓글 달기