Power button does not work after dissembling/reassembling

Hello everyone,

After dissembling and reassembling the YP-P3 (by following this guide Samsung YP-P3 Battery Replacement) to check the serial number on the battery, the player won't turn on when I hold down the power button.

Though for some odd reason when I connect it via USB to my desktop or any USB wall charger, it will turn on normally (i.e starting animation and sound followed by loading my wallpaper). For the desktop, my computer recognizes it as I can access the files and for the charger I can see the charging animation on the screen.

However when I disconnect the cable it won't show the ending animation and sound which the screen will turn completely black instead.

I'm not sure what caused such problem but on the first attempt of reassembling there was a slight problem with the circuit board and the battery heating up randomly. To be more specific, as soon as I connect the battery prong into the board I can gradually feel the board heating up as well as smelling something similar to burning. I immediately took the prongs out in which I waited 10 minutes and put it back in again - this time there were no heating or burning smell.

All in all, I'm not sure if this problem caused the power button to not work.

Another point I'd like to mention is before dissembling the player I've charged the battery 100% (i.e seeing "charging complete" on the screen). Now when I connect it via wall charger it shows that the player is charging. I haven't left it charging as I'm not sure if it'll damage my player even further or not.

Did I screwed up something during dissembling/reassembling? What are the solutions I could try?

Sorry if my explanation is a bit "wonky". Please let me know if you need any other information.

Thank you and I greatly appreciate your help.

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

Bumping.....

의 답변

코멘트 추가