주요 콘텐츠로 건너뛰기

모델 A1225 / Early 2009 / 2.66, 2.93, 또는 3.06 GHz Core 2 Duo 프로세서

164 질문 전체 보기

iMac alive but dead...

I've got this old iMac that I'm trying to get up and running again. When I hit the power button, the fans kick in and I can hear those classic iMac mechanical sounds. The only hitch is that it seems to stay in that state forever. No startup chime, just a black screen.
After opening up the iMac whent to take a look at the the diagnostic LEDs, When I connect the power cord to the iMac, the first LED illuminates. Then, when I press the power button, the second LED lights up. However, the third and fourth LEDs in the sequence do not turn on.

I've actually tried taking out the RAM and giving it a shot, and guess what? It actually beeped, just like it's supposed to! So, I don't think it's completely dead after all.

Next up, I'm gonna swap out the PRAM battery, even though I'm not entirely convinced that's the problem. I might also replace the RAM, but here's the thing—I don't have the right RAM on hand. Do you know of any other way to test those RAM sticks? I'll take off the Airport card and give it a shot. I'm curious to see if removing it will have any impact. Any tips would be awesome!

By the way, a little backstory on this iMac. It actually belonged to a friend of mine, but it's been gathering dust on his desk for ages. Apparently, he stopped using it around 4 or 5 years ago and stashed it away in a garage or something like that. Unfortunately, it was exposed to high humidity due to its proximity to the sea, which only made oxidation worse. Becouse of that, I'm thinking of going for the rather boring option of completely disassembling everything and cleaning each piece with alcohol. It might seem a bit radical, but I'm considering it as a last resort.

So, after being neglected for all those years, he decided to give it another shot, and you know what? It actually started up and ran for a little while before unexpectedly shutting down. Years later, here I am, stepping in like a tech wizard, attempting to work my magic and bring this forgotten iMac back to life. Who knows? Maybe I can pull off a miraculous revival here!

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기

답변 1개

가장 유용한 답변

If you disconnected the displays cables these last LEDs won’t light up. If you are lucky to have the service cable extensions you can have the display to the side with lots of access. Without the cable extensions you need to be careful not to pull on them as you can damage the logic board LVDS connector.

Can you post some pictures of the logic board connector so we can check it out. Need a set of sharp and tight images looking into the mouth of the connector as well as the side a bit.

해당 답변은 도움이 되었습니까?

점수 1

댓글 2개:

I'll send some asap. Before I decided to open up the Mac, the situation remained unchanged. I suppose I didn't accidentally disconnect any cables or cause any damage in the process. If there was a startup chime but no display on the screen, my initial assumption would be that there could be an issue with the LCD cable, the LCD itself, or even the graphics card. However, no startup chime so problem may lie elsewhere maybe?

The iMac was previously opened, I will check for broken cables, connectors, etc...

댓글 달기

귀하의 답변을 추가하세요

Afonso 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 6

30일 전: 9

전체 시간: 34