주요 콘텐츠로 건너뛰기

6MB 공유 L3 캐시 2.0GHz, 2.3GHz, 또는 2.6GHz 쿼드-코어 Intel Core i7 프로세서 (Turbo Boost 최대 3.8GHz).

572 질문 전체 보기

MacBook Pro 15 inch Late 2013 suddenly turns off

A friend's MacBook Pro 15 inch Late 2013 randomly shuts down itself. I tried reinstalling the system after I found out that the error does not occur in recovery mode. But this did not solve the problem. The problem is also not reproducable by any interaction.

There is no difference whether it is connected to the power supply or running on the battery. If you leave the MacBook powered off for some hours it may sometimes last over two hours before shuting down again. After the frist sudden shutdown the frequency of shutdown rises rapidly.

Also the shutdown might not be triggered by overheating. I tried benchmarking while watching temps after the reinstall of the OS and it lasted over two hours. 5-10 minutes after I stopped and the tempreture dropped the problem occured again.

My friend also sent the MacBook to Apple for a hardware test several times, but no problems were found yet.

I'm thinking about replacing the logic board.

Any opinion would be apprechiated.

EDIT 01/03/2017

I have not noticed anything while booting and there have not been any video problems apart from the blackscreen when the sudden shutdown occurs. (I have found this: Exchange and Repair Extension Programs - MacBook Pro video issues But, it does not match my friend's MacBook.)

The built-in hardware diagnostic tool stats that everything is correct. Maybe I should start the MacBook in verbos mode and videotape the output?

My friend will take the MacBook to an authorized service providor to have it taken apart, cleaned and the stained display replaced Apple StainGate Maybe they will find something...

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 11
댓글 9개

Have you ever seen any screen anomalies, any artifacts, beach balls when loading, a pause when booting up with the progress bar ranking about 50-60% of the way through?

I am having almost the same issue. The genius bar did not solve the problem.

I changed the battery, it did not change anything... but Logic boards are really expensive..

Do you have some problem identified when you press D at startup to enter diagnostic mode?

Same exact issue here!!! Any fix?

same problem here...

I seem to have the same thing: screen goes black, keyboard remains illuminated for a few seconds, then shuts down completely. No errors in the console when I restart. Apple Hardware Test says everything is fine. I've been using smcFanControl to monitor temperature and it's been shutting down at temperatures in the 40s centigrade.

댓글 4개 더보기

댓글 달기

답변 9개

선택된 답변


I’ve had the same problem with mine. The crew at the Apple Store,, after several tests said that it could be the motherboard. I searched the internet and found the solution in this Random Shutdown on MacBook Pro

I did this in June 2018, and my MacBook Pro works flawlessly since.

FYI - The problem is faulty power chips on logic board! (FDMF6808 to be precise. Should be replaced with newer FDMF6708).

We turned off one driver, that is for Ethernet via thunderbolt. Somehow it helps with our problem. It is possible, you don’t need that functionality, like me.

해당 답변은 도움이 되었습니까?

점수 6

댓글 5개:

similar issue - frequent shutdowns. Traced to CPU overheating. Placed a fan next to it and problem is addressed. Either it is a heatsink issue or fans are not working that well. used iStatMenu to monitor temperature. Mine is a late 2013 MacBook pro 15 inch.

Just did this and am currently running 12 applications (one being google chrome with a bunch of tabs open and another being photoshop with a few projects open). Playing music through bluetooth headphones and playing a video (on silent) on youtube in the background...MacBook seems to be holding steady and not overheating at all. 16 GB of memory installed helps. THANK YOU FOR THIS FIX!

I was 6 months into trying to fix this problem. Went thru most of people did: search Apple site for answer, no straight forward one; brought to Apple store to run checks, no problem found, wiped everything out and reinstalled OX, no fix. Run diag, no issues found no fix. Finally came across this site. It worked! Thanks for such a good way to fix this Apple's problem and it does make sense: MBP worked fine when in recovery mode indicating that it is not a hardware related problem, and only thing left is software related. We the ordinary user just not knowledge enough to find this fix. Much appreciate it!

Vincent, I followed the instructions in that linked and renamed my kext file as it said, then rebooted and immediately I noticed my Kensington trackball drivers were in control of my trackball again, and so far no shutdowns ... but I'm only about 10 minutes into it. I'm usually shut down by this point though, so I have high hopes for this solution. Thank you!

It’s the GPU related and usually the U8900 ISL chip has a cold solder. Fixed mine by resoldering the connection.

댓글 달기

David Rojas posted a link ^ that absolutely had the solution for me. (I reposted the steps below). When I first started experiencing the problem, it felt like hardware, but logically it didn’t make sense since as others said, it didn’t happen while in recovery mode. But as the days rolled on … it seemed like the CPU was spiking rapidly and it was heating up rapidly and it seemed like it was going into thermal shutdown … I found a program that lets you control your fans by your own rules and with that I was able to keep it from shutting down unless it was under extreme load … so that made it feel like a hardware problem, so I did what most techs would do with an 8-year-old laptop … I replaced the thermal compound… but it didn’t fix it… Then I stumble in here and Mr. Rojas had the answer.

Since links go down over time, I’m reposting the steps here that fixed this problem for me:

Reboot into recovery mode holding down CMD+R after boot chime, then open Terminal.

csrutil disable

Reboot normally - open Terminal

(If you have Catalina): sudo mount -uw /  ←don’t forget the forward slash
sudo cd /System/Library/Extensions
sudo mv AppleThunderboltNHI.kext AppleThunderboltNHI.kext.BAK

Reboot again into recovery mode and open Terminal

csrutil enable

Reboot one last time normally and you’re done!

해당 답변은 도움이 되었습니까?

점수 4

댓글 9개:

The system will not let me change the directory.

The steps work up to that point.

-- Nevermind. I forgot I wasn't logged in as the main admin.

I was able to change the filename. Hope it works!

hi all, we had a client who had this exact issue that most on here are dealing with,

not sure it'll be the answer for all of you, but after searching for about a day, this solution that someone gracefully shared on https://apple.stackexchange.com/question... seems to have solved our issue.

just a note: the solution seems to modify a thunderbolt file, some mention that external thunderbolt displays will sometimes require a reboot to work, however it beats having to pay $400+ for apple to service your laptop.

=== Update (05/14/2020) ===

''Thanks Mike Sims, i can't take any credit.''

just helping lead others to answers others have gracefully shared, and get a little more life out of these Macs.

that being said:

New update:

as of the MacOS 10.15.4 Update the fix above stops working. however,

credit:OlivierFelix for the continued fix:


In summary this is what i did to get the mac back up and running:

Reboot into recovery mode holding down CMD+R after boot chime, then open Terminal.

[code]csrutil disable[/code]

Reboot normally - open Terminal

[code](If you have Catalina): sudo mount -uw / ←don’t forget the forward slash[/code]


sudo cd /System/Library/Extensions

sudo mv AppleThunderboltNHI.kext AppleThunderboltNHI.kext.BAK


(New as of10.15.4) in addition to the NHI move performed above now add the step below as well:


sudo cd /System/Library/Extensions

sudo mv IOThunderboltFamily.kext IOThunderboltFamily.kext.BAK


Reboot again into recovery mode and open Terminal

[code]csrutil enable[/code]

reboot normally.

Update: fix is still working fine, however, It seems as though if you have tried the fix above and then do a OSX upgrade, Mac restores the modified file (random shutting off starts again)

in our environment we have pushed everyone to macOS Mojave, i noticed that on this new macOS the terminal command might not work.

"sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK" as it did not work in my case, I simply opened Finder, and went to the file location above, renamed it manually then proceed with the steps listed in the link above and the user has been good ever since.

Hello, I have tried this process and it doesn't seem to be working for me. I don't know if I'm doing it incorrectly?

I'm on 10.5.5.

When I go into terminal and add "sudo mv AppleThunderboltNHI.kext AppleThunderboltNHI.kext.BAK" It says "mv: rename AppleThunderboltNHI.kext to AppleThunderboltNHI.kext.BAK: No such file or directory"

Try to type this instead (all in one move "no Command Directory") :

sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK

댓글 4개 더보기

댓글 달기

Hello all,

I struggled with my late 2013 Macbook pro shutting down and read all the forums and followed all the fixes I could find, all to no avail :(

Here’s the fix I was enlightened to which saved me —a $10 cost but immediate solve of my computer crashing problems! Like magic!


해당 답변은 도움이 되었습니까?

점수 1
댓글 달기

Type "syslog | grep shutdown" into terminal and post the results.

I've experienced this before on a 2012 rMBP and it turned out to be bad memory, which resulted in a logic board replacement. See if you can run MemTest86 to confirm.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

My Macbook Pro kept shutting down then would not powder on.

I replaced my AC cord.

They do wear out.

If this works for you, check to see if you battery is charging this can take up to 3 hours.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기


It is not a temp related issue. It is a core voltage issue.

해당 답변은 도움이 되었습니까?

점수 0

댓글 6개:

Glad I found this resource as this problem's been driving me crazy! I've set up the NoCrashMBP as recommended by adambarscheski and will report back if it doesn't take care of things...

@adambarscheski thank you for providing this awesome fix - I downloaded and installed and so far no more crashes (fingers crossed!!!). At the peak I was experiencing crashes every 2.5 mins and was about to chuck my MacBook in the bin - so US$15 to save $US2000 seems like pretty great value. Super fast and responsive tech support too - much appreciated.

@adambarscheski Wow! After consigning my 2013 MacBook Pro to the junk pile for the last two years, I thought I'd have one last stab at trying to solve my shutdown problem. Before shelling out another £1800 for a new computer, I thought I'd try the $10 option from yourself. It actually worked!!! I'm so grateful and ecstatically happy right now :)

Go with adambarscheski's solution. See my comment above from April. adambarscheski's solution worked perfectly for me.

Why pay someone?

This little script solved the random shutdown issue for my 15" mbp mid 2014:



댓글 1개 더보기

댓글 달기

I went for a repair and Apple fixed it on warranty ;-)

Got a new logic board!

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Under System Preferences > Security and Privacy > General > open the lock in the bottom left-hand corner, enter your admin password and then click Advanced. If you have "Log out after x minutes of inactivity" checked, either increase that number or uncheck that box.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기


I am having the same problem. I have macbook pro retina early 2013 running Catalina 10.15.7. I tried to run sudomv/System/Library/Extensions/AppleThunderboltNHI.kext/System/Library/Extensions/AppleThunderboltNHI.kext.BAK

it keeps saying command not found.

any solutions?? please help

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:

Check your battery! Install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see 기존 질문에 이미지 추가하기

There's supposed to be a space between "sudo" and "mv". Otherwise, Terminal will think you're trying to execute "sudomv", which isn't a real command.

댓글 달기

귀하의 답변을 추가하세요

hemdaaaraaa 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 5

7일 전: 52

30일 전: 192

전체 시간: 25,868