주요 콘텐츠로 건너뛰기

2009년 6월 출시 / 2.66, 2.8, 또는 3.06 GHz Core 2 Duo 프로세서

296 질문 전체 보기

SMC / power / charging circuit problem

My macbook pro has had a hardware fault since I tried a replacement battery in it, one from ebay :(

Needless to say that battery is out of the equation now, but I still have a persistent fault. I initially tried all SMC/RAM resets, but it's a hardware fault for sure.

The machine will now only boot from a mains power source. The mag light stays green always but the battery icon is an x. Coconut Battery can't get _any_ details, charge, temp, etc all unavailable.

It's been this way for a while, such that now the internal battery is flat I expect, I can now only boot it via SMC bypass, leaving fans on full blast and there is now no battery icon at all. I'll get a new battery, if I thought the Logic board could be fixed.

I wondered if something in the SMC circuit area could be fried.

I've removed the whole logic board and carefully cleaned it up. I looked for any signs of damage, a burnt component or track but alas it all looks fine.

Are there some parts of the SMC circuit I can check, maybe some FETs or the SMC chip are dead, I could attempt to test/replace perhaps, if I knew where to look.

Any ideas?


Interestingly just noticed that while coconut can't find any battery stats at all (and maybe the battery is flat=dead now too) - it does say it can't detect a power source. It says Power Adapter: No Adapter Found. A clue maybe?

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 9
댓글 달기

답변 5개

가장 유용한 답변

LouisJB, let me "pipe up" for a second. First thing I suggest is that you check your charging fuse F7040. Use a multimeter and see if you have continuity. If you do not replace it with a 8A 24V 1206 SMC fuse.

Block Image

Charging is controlled by U7000 which is a ISL6258A It is a 28 pin QFN package,7 solder pads each side. It communicates with the SMC to activate charging and then uses a push-pull FET circuit to generate the charging voltage. There is a current sensing resistor R7050 just at 3 o'clock position from the fuse (the green device) that feeds back the charging current information to U7000. It is a 0.01 ohm 0.5% 1W sensing resistor in a 0612 package.Check those components first and see what you get. You do want to check the components around the charging IC U7000.

Block Image

해당 답변은 도움이 되었습니까?

점수 12


Thanks OT, I knew you had the info at hand! Hope you had a good T-Day.

aha that's excellent info, I shall be checking those things for sure! Imagine if it was just that fuse, that would be fantastic.

It originally was that the machine would only boot from PSU but boot normally, with no battery recognised (x-icon). So it made an Ok desktop for now, since I got a new quad-core i7 to replace it as my main, portable machine.

However, since the internal battery is not charging, I think it's now completely flat.

It's now harder to start the machine. For example it won't start normally anymore, you have to do the SMC bypass (hold the power down while connecting PSU), then when it starts it starts with fans full speed etc.

Is the latter starting issue just a symptom of my flat battery? If I fix the logic board will it have any hope to charge the flat battery? sort of in a catch-22 where I need to buy a new battery but can't until the machine can charge it, or it will die again in time. Yet without one its difficult to test or be sure it's fixed :)

Yes it will and yes it does. So you have to make a decision about the battery. You are right, it might be money spend and still not get it working, since you are just at the beginning stages of trouble shooting. The error could be further down the line.....

Ok, it's what I thought, thanks for confirming. I've wired it up as a desktop for now. I've also disconnected the fans and the battery indicator as well. Might sound dangerous but it's running ok, it's go slow/shut down or crash if it gets too hot but I'll keep an eye on it. It's got more than enough CPU grunt for normal stuff without getting very warm at all. Seems so much of the board is working just fine it ought to be possible to fix this, so long as it doesn't come to SMC replacement. In that case I'll have to look for a replacement LB second-hand, but they sure seem to fetch a high premium right now! I want to avoid making it any worse by accident, as it is usable right now. Think I'll get some fine probes for the meter before measuring anything. Wow some of those components are really small! If I can locate a schematic for that model's charging circuit, I'd like to see how the fuse, sensing, I2C comms & the charging FETs are wired with the battery, perhaps then I can start making more measurements.

Got a schematic for A1286, think it's close enough.

Found those components. Tracing the diagram for candidates to check, I have a few questions.

What does R7020 do, looks like another sense resistor (0.02 Ohms)? Some part of a protection circuit?

Also Q7055 and Q7056, also protection?

I wonder if R7051 / 7052 might be worth checking also, from the current sense resistor to U7000

2에 댓글 더 나타내기

댓글 달기

At this point I suspect the charging circuit is in trouble (on the logic board).

There are a few MosFET's and a comparator logic that often get burnt. Often you can see them damaged. Look right behind the battery connector there you will find 2 four pin MosFET's (with a larger fifth pin on the other side).


The SMC is a micro-controller that gets the input from the comparator logic.

Sure, its possible the SMC is damaged as well. But, you need to work upto it from the battery & charger circuit. I don't remember seeing the SMC fail with all of our systems.

Static is the the big killer here. One thing we've discovered is the carrying cases we had used would discharge into the MagSafe connector when the laptop was put in or out.

Also with the colder weather moving in, the air gets dry so its also important to be doubly careful when opening systems (using ESD safeguards).

As to testing MosFET's:

On the most part unless you have the tools, skills and access to the parts this is something you should hand over to a person with SMT skills.

해당 답변은 도움이 되었습니까?

점수 5


Dan, can you test theses mosFET's onboard or you have to remove them from the board. If you can test them onboard what is the procedure ? Charger IC can also be the culprit.

Ok great, thanks Dan. That gives me somewhere to start looking.

Could this prevent the SMC IO from running, perhaps the SMC isn't powering up as a consequence? It might be tricky also now with a dead battery but if there's a chance I can fix this I'll get a new battery.

Anything I can measure while running off of the PSU, perhaps some voltages around the FETs?

Lemerise - Yes, the comparator logic (Charger IC) can get fried as well.

I found some of the relevant components. Again no visual signs of issue. There's what I think is the charging IC, small square with label starting i 625... and two 5 pin mosfets up in the top corner of the board. I hope you're right regarding SMC, so long as that chip hasn't blown maybe it's fixable (as I doubt I could swap the SMC without risk of damage).

I've a soldering iron and a background in electronics. I used to regularly swap huge QFP FPGA chips with just an iron. However admittedly some of the SMC on this logic board is super tiny and I've nothing like a hot air gun for swapping more complex components, so I'll try all the simpler options. Will get a broken board for spares if I find a likely candidate component for replacement.

Machine runs ok in SMC bypass.

What sort of faults could prevent boot without SMC bypass. Could charging & comparator faults lead to this symptom? I found the 020 resistor that I think is the current sensing resistor.

oh, the upper of the logic board has label 820-2523-B (i7 2.8GHz for what it's worth) - is there anywhere I could find a schematic and a parts location diagram (specifically around SMC/Charging/power control), this would be really useful.

2에 댓글 더 나타내기

댓글 달기

I ran across this thread while looking for other things and thought I could add something that could help the original poster or anyone in the same situation. Rather than typing the explanation and how to fix this problem, which I don't think is as serious as you may think... I am going to provide a youtube link for something very similar.

This thread is a little old but seems to not have been fully answered or resolved so I am going to try to add something.


Assuming this computer is still in the same condition as before, there is an important 3.3V power supply that must be present on the board for the charger and everything to activate correctly. This power supply is responsible for providing power to something called a one-wire circuit which allows the SMC to communicate with the battery and charger. Before power will be allowed into the computer (assuming you have not done the SMC bypass) some conditions appear to have to be satisfied including communicating with the charger and battery.

This 3.3V power supply (more like 3.5V) is actually on all the time even when the computer is powered off. As in the video above, you should check this power supply, assuming you have access to the board schematics and board layout, and it may be something as simple as a single resistor or fuse that went out that is preventing this power supply from turning on and therefore disallowing ever other power rail in the system from being turned on.

해당 답변은 도움이 되었습니까?

점수 2
댓글 달기

You shorted the battery terminals to the data line terminals. Hello 12 volts to the SMC data line, fix pins and replace SMC because it is toast, along with your battery indicator LED>

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

I had the exact same problem a while ago, and fixed it relatively easily. The problem in my case was that I was using an aftermarket power cord/supply that provided the wrong wattage. Your computer should be using an 85W supply (based on this link from Apple). Check the power brick to see if you may be using a 60W supply, like I was. Replacing it with an 85 Watt one should fix the problem if this is it.

If that doesn't work, check out this link where there is a long discussion about fixing this problem.

해당 답변은 도움이 되었습니까?

점수 0

1 Comment:

Nonsense, you can use any larger one one a smaller mac, like a 85 Watts on an 11 inch air that uses a 45Watt standard. If using a smaller one on a larger capacity unit, it just will not charge enough to keep it running while in use but wont damage it. There is absolutely NO issue using a different wattage, if you use cheap as copy cat chargers, thats another story though on this point you were right.

댓글 달기

귀하의 답변을 추가하세요

LouisJB 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 7

30일 전: 28

전체 시간: 28,235